Hi,

I converted a SVN repository back in March using svn2git, and it ran fine.
As the live migration approaches I tried to run the conversion tool again
and I got a core dump a point in the SVN history that previously was fine.
When I ran the tool in March it didn't fail at this point:

warning: core file may not match specified executable file.
[New LWP 27090]
[New LWP 27092]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `/u01/svn/svn2git/svn-all-fast-export --svn-ignore
--add-metadata --identity-map'.
Program terminated with signal 6, Aborted.
#0  0x00007ffdfefde1d7 in __GI_raise (sig=sig@entry=6) at
../nptl/sysdeps/unix/sysv/linux/raise.c:56
56        return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt
#0  0x00007ffdfefde1d7 in __GI_raise (sig=sig@entry=6) at
../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007ffdfefdf8c8 in __GI_abort () at abort.c:90
#2  0x00007ffdffe177b4 in qt_message_output (msgType=msgType@entry=QtFatalMsg,
buf=<optimized out>) at global/qglobal.cpp:2323
#3  0x00007ffdffe17959 in qt_message(enum QtMsgType, const char *, typedef
__va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg,
    msg=msg@entry=0x438d38 "Failed to write to process: %s",
ap=ap@entry=0x7fff83b86d60)
at global/qglobal.cpp:2369
#4  0x00007ffdffe18261 in qFatal (msg=msg@entry=0x438d38 "Failed to write
to process: %s") at global/qglobal.cpp:2552
#5  0x000000000042228d in QIODevice_write (baton=0x2ddc218, data=<optimized
out>, len=<optimized out>) at svn.cpp:237
#6  0x00007ffe0034f4a8 in svn_stream_copy3 (from=0x2fbda70, to=0x2fbdf80,
cancel_func=0x0, cancel_baton=0x0, scratch_pool=<optimized out>)
    at subversion/libsvn_subr/stream.c:503
#7  0x000000000042262e in dumpBlob (txn=txn@entry=0x518d7c0,
fs_root=fs_root@entry=0x2840820, pathname=<optimized out>,
finalPathName=...,
    pool=pool@entry=0x2b4d148) at svn.cpp:297
#8  0x0000000000423fff in recursiveDumpDir (txn=txn@entry=0x518d7c0,
fs_root=fs_root@entry=0x2840820, pathname=..., finalPathName=...,
    pool=pool@entry=0x3ef69a8) at svn.cpp:340
#9  0x0000000000423f53 in recursiveDumpDir (txn=txn@entry=0x518d7c0,
fs_root=fs_root@entry=0x2840820, pathname=..., finalPathName=...,
    pool=pool@entry=0x3efa9c8) at svn.cpp:335
#10 0x0000000000423f53 in recursiveDumpDir (txn=txn@entry=0x518d7c0,
fs_root=0x2840820, pathname=..., finalPathName=..., pool=pool@entry
=0x31aaa18)
    at svn.cpp:335
#11 0x0000000000426e07 in SvnRevision::exportInternal (this=this@entry
=0x7fff83b882c0,
    key=key@entry=0x4fa6e48
"/ConfigurationDeploymentServer/branches/dan/VmAutoProvision/roles",
change=change@entry=0x31aaf68,
    path_from=<optimized out>, path_from@entry=0x0, rev_from=rev_from@entry=-1,
current=..., rule=..., matchRules=...) at svn.cpp:914
#12 0x000000000042b56b in SvnRevision::exportDispatch (this=this@entry
=0x7fff83b882c0,
    key=key@entry=0x4fa6e48
"/ConfigurationDeploymentServer/branches/dan/VmAutoProvision/roles",
change=change@entry=0x31aaf68, path_from=0x0,
    rev_from=-1, changes=changes@entry=0x31aaa90, current=..., rule=...,
matchRules=..., pool=pool@entry=0x2c20da8) at svn.cpp:716
#13 0x000000000042cff0 in SvnRevision::exportEntry (this=this@entry
=0x7fff83b882c0,
    key=0x4fa6e48
"/ConfigurationDeploymentServer/branches/dan/VmAutoProvision/roles",
change=0x31aaf68, changes=0x31aaa90) at svn.cpp:666
#14 0x000000000042f091 in SvnRevision::prepareTransactions
(this=this@entry=0x7fff83b882c0)
at svn.cpp:536
#15 0x000000000042f660 in SvnPrivate::exportRevision (this=<optimized out>,
revnum=revnum@entry=476966) at svn.cpp:444
#16 0x000000000042f7ec in Svn::exportRevision (this=this@entry=0x7fff83b88460,
revnum=revnum@entry=476966) at svn.cpp:154
#17 0x0000000000407754 in main (argc=8, argv=<optimized out>) at
main.cpp:276
(gdb) q

This branch was fine the last time I ran the conversion. I can't think what
the difference might be, it's the same machine that I ran it on in March.
The only difference I can think of is that I have using Subversion 1.8. I
can't be sure but I think that svn2git must have a dependency on
subversion-devel libraries, so if they are a different version that might
be the cause of the problem. I am not sure though. Any suggestions greatly
appreciated.

Regards,
John

Reply via email to