Hi, 
I use the same kea versions (configured with hosts reservations and lease
storage in MySQL) and get the following message after a DISCOVER is
received:

15 Aug 15:23:32 kea-dhcp4       warning WARN [kea-dhcp4.alloc-engine]
ALLOC_ENGINE_V4_ALLOC_FAIL [hwtype=1 f8:1a:67:6e:0b:4f], cid=[no info],
tid=0x53a62bf0: failed to allocate an IPv4 address after 0 attempt(s)

After, I made a packet capture and identified the some packets that arrive
to DHCP server doesn't include a client-identifier option.

According to Kea-docs and supposing that this field is the problem, I
changed configuration of subnet, adding the following entry:
"match-client-id": false 
Unfortunately, that doesn't solved the problem and the client doesn't
receive a DHCP packet in respose.
Please, help, advice, how could be solved this situation?
 
(just if someone need to know: the clients get to the DHCP server via a
relay and all other clients which have filled the cid field receive
succesfully IP addresses from the KEA DHCP server, and I checked to be sure
that for the indicate MAC address I have a host reservation).



--
Sent from: http://kea-users.7364.n8.nabble.com/
_______________________________________________
Kea-users mailing list
Kea-users@lists.isc.org
https://lists.isc.org/mailman/listinfo/kea-users

Reply via email to