Why is this commit not included here?
commit f95dc207b93da9c88ddbb7741ec3730c6657b88e
Author: Jens Axboe <[email protected]>
AuthorDate: Tue Aug 31 13:57:32 2021 -0600
Commit: Jens Axboe <[email protected]>
CommitDate: Wed Sep 1 12:35:30 2021 -0600
io-wq: split bounded and unbounded work into separate lists
We've got a few issues that all boil down to the fact that we have one
list of pending work items, yet two different types of workers to
serve them. This causes some oddities around workers switching type and
even hashed work vs regular work on the same bounded list.
Just separate them out cleanly, similarly to how we already do
accounting of what is running. That provides a clean separation and
removes some corner cases that can cause stalls when handling IO
that is punted to io-wq.
Fixes: ecc53c48c13d ("io-wq: check max_worker limits if a worker
transitions bound state")
Signed-off-by: Jens Axboe <[email protected]>
I guess because it was added before v5.15 final, but it's critical to have,
see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1952222
** Changed in: linux (Ubuntu Impish)
Status: Fix Committed => Incomplete
--
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1955070
Title:
Impish update: upstream stable patchset 2021-12-16
Status in linux package in Ubuntu:
Invalid
Status in linux source package in Impish:
Incomplete
Bug description:
SRU Justification
Impact:
The upstream process for stable tree updates is quite similar
in scope to the Ubuntu SRU process, e.g., each patch has to
demonstrably fix a bug, and each patch is vetted by upstream
by originating either directly from a mainline/stable Linux tree or
a minimally backported form of that patch. The following upstream
stable patches should be included in the Ubuntu kernel:
upstream stable patchset 2021-12-16
Ported from the following upstream stable releases:
v5.10.81, v5.14.21, v5.15.4
from git://git.kernel.org/
Note: upstream stable v5.14 has now reached EOL, as of
v5.14.21.
fortify: Explicitly disable Clang support
block: Add a helper to validate the block size
loop: Use blk_validate_block_size() to validate block size
bootconfig: init: Fix memblock leak in xbc_make_cmdline()
net: stmmac: dwmac-rk: fix unbalanced pm_runtime_enable warnings
parisc/entry: fix trace test in syscall exit path
PCI/MSI: Destroy sysfs before freeing entries
PCI/MSI: Deal with devices lying about their MSI mask capability
PCI: Add MSI masking quirk for Nvidia ION AHCI
erofs: remove the occupied parameter from z_erofs_pagevec_enqueue()
erofs: fix unsafe pagevec reuse of hooked pclusters
perf/core: Avoid put_page() when GUP fails
thermal: Fix NULL pointer dereferences in of_thermal_ functions
selftests/x86/iopl: Adjust to the faked iopl CLI/STI usage
KVM: Fix steal time asm constraints
Bluetooth: btusb: Add 0x0b05:0x190e Realtek 8761BU (ASUS BT500) device.
Bluetooth: btusb: Add support for TP-Link UB500 Adapter
string: uninline memcpy_and_pad
btrfs: introduce btrfs_is_data_reloc_root
btrfs: zoned: add a dedicated data relocation block group
btrfs: zoned: only allow one process to add pages to a relocation inode
btrfs: zoned: use regular writes for relocation
btrfs: check for relocation inodes on zoned btrfs in should_nocow
btrfs: zoned: allow preallocation for relocation inodes
UBUNTU: upstream stable to v5.10.81, v5.14.21, v5.15.4
To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1955070/+subscriptions
--
Mailing list: https://launchpad.net/~kernel-packages
Post to : [email protected]
Unsubscribe : https://launchpad.net/~kernel-packages
More help : https://help.launchpad.net/ListHelp