I'm not sure if this is of any help, but I've had trouble with Suyin
webcam on my Asus laptop running the 3.16.0-31 kernel. Kernel
3.13.0-37.64 worked well...

Here is the hw id:
Bus 001 Device 003: ID 064e:9700 Suyin Corp. 
in skype the video screen from me and remote was black and I noticed error
libv4l2: error dequeuing buf: Invalid argument
and guvcview didn't show any video either. It was just flooding the console 
with "Ignoring empty buffer ..." messages.

I've tried testing ppa from Paulo and after installing the following packages:
ii  guvcview                                    
2.0.1+ubuntu2~ppa1+1278-0ubuntu0~201501091246~ubuntu14.04.1 amd64        GTK+ 
base UVC Viewer
ii  libguvcview-1.0-1:amd64                     
2.0.1+ubuntu2~ppa1+1278-0ubuntu0~201501091246~ubuntu14.04.1 amd64        GTK+ 
base UVC Viewer - runtime
the problem magically went away - in skype too..

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  uvcvideo doesn't work with USB webcam with linux 3.16

Status in The Linux Kernel:
Status in linux package in Ubuntu:

Bug description:
  uvcvideo doesn't work with linux 3.16 on at least two USB webcams.

  guvcvideo shows a black screen and reports "Could not grab image" or
  "ignoring empty buffer".

  The camera works fine with Motion or Skype in linux 3.16. guvcvideo
  works fine with linux 3.15.

  There is more info at

  ProblemType: Bug
  DistroRelease: Ubuntu 14.10
  Package: linux-image-3.16.0-10-generic 3.16.0-10.15
  ProcVersionSignature: Ubuntu 3.16.0-10.15-generic 3.16.1
  Uname: Linux 3.16.0-10-generic x86_64
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC0:  rocko      1894 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Wed Aug 27 17:26:27 2014
  HibernationDevice: RESUME=UUID=e586cc1f-5429-445e-b3fa-d15a1f5b54a0
  InstallationDate: Installed on 2014-08-22 (5 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
   eth0      no wireless extensions.
   lo        no wireless extensions.
   Bus 001 Device 002: ID 0408:2fb1 Quanta Computer, Inc. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: innotek GmbH VirtualBox
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-10-generic 
root=UUID=fa1da5bc-d7d9-40bf-9d26-ad7bcf1ab6bc ro quiet splash vt.handoff=7
   linux-restricted-modules-3.16.0-10-generic N/A
   linux-backports-modules-3.16.0-10-generic  N/A
   linux-firmware                             1.132
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/01/2006
  dmi.bios.vendor: innotek GmbH
  dmi.bios.version: VirtualBox
  dmi.board.name: VirtualBox
  dmi.board.vendor: Oracle Corporation
  dmi.board.version: 1.2
  dmi.chassis.type: 1
  dmi.chassis.vendor: Oracle Corporation
  dmi.product.name: VirtualBox
  dmi.product.version: 1.2
  dmi.sys.vendor: innotek GmbH

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to