This issue affects me as well.  Lenovo T460 and a Lenovo basic docking
station.  The docking station is connected to an Acer 24" monitor via
VGA.  Once the desktop locks and the unity login appears the external
display enters power save mode.  Unlocking via the password does not
power up the external display (all windows are moved to laptop display).
I have to eject the laptop from the dock, wait a couple of seconds, then
put the laptop back in the dock for the external display to power back
up.  I'd prefer not to physically undock/dock the laptop several times a

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [dp] External Screen doesn't wake up from sleep

Status in linux package in Ubuntu:

Bug description:
  I have a Lenovo X1 Carbon with an external screen connected to a Mini DP to 
VGA adapter. External screen works fine until the display goes to sleep for 
inactivity (just the display goes to sleep, not the laptop).
  When I return to the laptop, the built in screen wakes but the external 
screen does not. The screen is still detected, xrandr displays the resolution 
and I can move the cursor to the external display but the display remains off.
  I have tried cycling with Fn+F7 and also tried Ctrl+Alt+F1 then Ctrl+Alt+F7. 
The only way to get the external display back on is by disconnecting the 
adapter from the laptops DP port and reconnecting.

  dmesg produces:
  drm:intel_dp_complete_link_train] *ERROR* failed to train DP, aborting

  Description:  Ubuntu 13.04
  Release:      13.04
  kernel 3.8.0-23-generic
    Installed: 2:2.21.6-0ubuntu4

  As a workaround I have disabled the monitor from sleeping in System 
Settings->Brightness & Lock-> Turn Screen off when inactive for
  ApportVersion: 2.12.5-0ubuntu2.2
  Architecture: amd64
   /dev/snd/controlC0:  omri       2408 F.... pulseaudio
                        omri       8582 F.... TeamViewer.exe
   /dev/snd/pcmC0D0p:   omri       2408 F...m pulseaudio
  DistroRelease: Ubuntu 13.10
  HibernationDevice: RESUME=UUID=d46a5b01-0285-4289-8345-692997c83409
  InstallationDate: Installed on 2013-10-19 (80 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 
  MachineType: LENOVO 3443CTO
  MarkForUpload: True
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-15-generic.efi.signed 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.11.0-15.23-generic 3.11.10
   linux-restricted-modules-3.11.0-15-generic N/A
   linux-backports-modules-3.11.0-15-generic  N/A
   linux-firmware                             1.116
  Tags:  saucy
  Uname: Linux 3.11.0-15-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm bluetooth cdrom dip lpadmin plugdev sambashare sudo 04/29/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G6ET96WW (2.56 )
  dmi.board.asset.tag: Not Available 3443CTO
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 Pro DPK TPG
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
dmi:bvnLENOVO:bvrG6ET96WW(2.56):bd04/29/2013:svnLENOVO:pn3443CTO:pvrThinkPadX1Carbon:rvnLENOVO:rn3443CTO:rvrWin8ProDPKTPG:cvnLENOVO:ct10:cvrNotAvailable: 3443CTO
  dmi.product.version: ThinkPad X1 Carbon
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to