I had the same problem and unsuccessfully tried:

1. the linux-firmware package from yakkety
2. kernel-4.6.3-yakkety
3. kernel-4.7.4
4. sudo modprobe rt2800pci nohwcrypt=Y
5. sudo iw reg set NL

While the newer kernels seemed to alleviate the problem, they didn't fix

Then I reverted all the previously listed changes and turned the card's
power management off. That fixed it. However, since power management
would turn on every time it would connect to a network, I made a simple
NetworkManager script, that you can find at

The following are some relevant info about my system:

$ uname -a
Linux precision390 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 
x86_64 x86_64 x86_64 GNU/Linux

$ iwconfig
wlp5s5    IEEE 802.11abgn  ESSID:"<edited>"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: <edited>   
          Bit Rate=270 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=42/70  Signal level=-68 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:133  Invalid misc:781   Missed beacon:0

$ apt list linux-firmware
Listing... Done
linux-firmware/xenial-updates,xenial-updates,now 1.157.3 all 

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Very slow wireless with rt2800pci

Status in linux package in Ubuntu:

Bug description:
  I have a Linksys WMP600N (rt2800pci driver). My wireless connection is 
extremely slow and unstable. I am using Kubuntu 16.04, with Kernel 4.4.0-36 or 
4.7.0-0. The speed test results are: DL: 2.02Mbps UL:0.05Mbps Ping:183ms , the 
speed test with another PC with the same wireless network : DL:12Mbps 
UL:1.20Mbps Ping:48ms.
  I have follow this guide: 
  But nothing is changed

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-36-generic 4.4.0-36.55
  ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
  Uname: Linux 4.4.0-36-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
   /dev/snd/controlC0:  andrea     3231 F.... pulseaudio
  CurrentDesktop: KDE
  Date: Tue Sep 13 14:28:22 2016
  HibernationDevice: RESUME=UUID=7237eef7-9261-4799-8955-b4466b0e5cb5
  InstallationDate: Installed on 2016-09-02 (11 days ago)
  InstallationMedia: Kubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
  MachineType: Gigabyte Technology Co., Ltd. M720-US3
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-36-generic 
root=UUID=83949c88-4099-41fa-a6fd-f143912ae477 ro quiet splash
   linux-restricted-modules-4.4.0-36-generic N/A
   linux-backports-modules-4.4.0-36-generic  N/A
   linux-firmware                            1.157.3
   0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/07/2010
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F7n
  dmi.board.name: M720-US3
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.product.name: M720-US3
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to