Just another observation - when my palm of the right hand touches the touchpad 
while using the touchpad, the touchpad behavior seems normal; also, when I 
place my left palm on the area to the left of the touchpad, the behavior seems 
also normal. 
However, as soon as I move my left hand away from the touchpad area, and I lift 
my right palm from the laptop, with only my finger(s) touching the touchpad, 
the behavior becomes erratic again.

So in a nutshell: It works when at least one palm touches the metal of
the area to the left or right of the touchpad; it does not work when
only a finger (or two) touches the touchpad itself.


You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Ubuntu 16.10 beta breaks Asus Laptop touchpad behavior

Status in linux package in Ubuntu:

Bug description:
  In 16.04 LTS, the touchpad behaved perfectly, and as soon as I stepped
  up to 16.10 beta the touchpad became unusable.

  When holding a single finger on the touchpad, without moving my
  finger, the cursor jumps around like crazy, and even performs clicks.
  When placing a second finger on the touchpad, without moving either,
  it gets even worse.

  See desktop recording clip as reference of the behavior (attached as

  The laptop is an Asus ZenBook UX31E.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: xorg 1:7.7+13ubuntu4
  ProcVersionSignature: Ubuntu 4.8.0-17.19-generic 4.8.0-rc7
  Uname: Linux 4.8.0-17-generic x86_64

  ApportVersion: 2.20.3-0ubuntu7
  Architecture: amd64
  BootLog: /dev/sda1: clean, 415810/7815168 files, 10983001/31258368 blocks
  CompizPlugins: No value set for 
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity:Unity7
  Date: Mon Oct  3 21:04:16 2016
  DistUpgraded: Fresh install
  DistroCodename: yakkety
  DistroVariant: ubuntu
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes, if not too technical
   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics 
Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. 2nd Generation Core Processor Family 
Integrated Graphics Controller [1043:1427]
  InstallationDate: Installed on 2016-03-17 (200 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160316)
  MachineType: ASUSTeK Computer Inc. UX31E
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-17-generic 
root=UUID=77be5fdd-c844-4d59-af29-cc718cf6b41a ro intel_state=disable 
pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 "acpi_osi=Windows 2009" 
"acpi_os_name=Windows 2009" quiet splash intel_state=disable pcie_aspm=force 
drm.vblankoffdelay=1 i915.semaphores=1 "acpi_osi=Windows 2009" 
"acpi_os_name=Windows 2009"
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/26/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: UX31E.210
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: UX31E
  dmi.board.vendor: ASUSTeK Computer Inc.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK Computer Inc.
  dmi.chassis.version: 1.0
  dmi.product.name: UX31E
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK Computer Inc.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.70-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.3-1ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.3-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu6
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2
  xserver.bootTime: Mon Oct  3 16:12:15 2016
  xserver.configfile: default

  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.18.4-1ubuntu6
  xserver.video_driver: modeset

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to