You have been subscribed to a public bug:

Minor bug - I have an annoying work around

ASRock Z170 Extreme7+ Mboard has 10 SATA 3 ports off 2 controller chips
CPU is Skylake 6700. One SATA chip does 6 ports in pairs which also
serve as either SATA Express or M.2 drive controllers. these are SATA
3-0 to SATA 3-5, other has 4 SATA ports. System worked in Win 7, but
when booting to Kubuntu 16.10 it kept coming crashing during boot with
an error of 'Unable to initiate SATA child Parent inactive.' I tried
every possible combination, and eventually got the system to load by
placing an Optical drive as SAT 3-0, and writing off one of the SATA
Express links. Once I got it going I started adding drives back in one
at a time, and hit the same problem when I got to the first SATA port on
the 2nd chip, and optical drive plugged in there soon fixed that.

Another issue was I couldn't create an M.2 drive as the system drive
while there was a hard drive connected to the system. Cut it back to
just the optical and the M.2 and it let me use the M.2 as the system

System now working with SATA 3-0 as optical, SATA 3-1 as 2TB HDD, SATA
3-2/3 as 500GB M.2, SATA 3 -4/5 as 500GB M.2, SATA 3A-0 as optical, SATA
3A-2 as  2TB HDD. Tested, as soon as I move an optical from the first
SATA port for the chip I get the error message during the boot-up and it
doesn't load. Switch back and it loads OK. I've a work around, but it
costs me a SATA Express line. However, you may see others with Skylake
chips havign the same issue.

I suspect it's an issue with the package checking the hardware during
the boot-up, but don't know enough to say for sure.

** Affects: linux (Ubuntu)
     Importance: Undecided
         Status: New

Crash due to SATA 3 issue in Skylake chip
You received this bug notification because you are a member of Kernel Packages, 
which is subscribed to linux in Ubuntu.

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to