This bug is missing log files that will aid in diagnosing the problem.
>From a terminal window please run:

apport-collect 1634593

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Elantech Touchpad detects as PS/2 BYD TouchPad or as a PS/2 generic

Status in linux package in Ubuntu:

Bug description:
  I have an Elantech Touchpad installed on my Lenovo Y700 laptop and I
  can't make it work properly by any means. I tried to switch between
  libinput and synaptics but this bug seems to affect any driver.

  Usually, after a system upgrade all works properly till the moment I
  plug in external mouse (Razer DeathAdder 3500DPI). After that touchpad
  detected as either PS/2 BYD or PS/2 generic mouse or sometimes PS/2
  Elantech touchpad.

  After some 5-6 reboots without plugging in external mouse the touchpad
  finally starts to detect it as ETPS/2 Elantech touchpad.

  Reloading psmouse module seems to cause no effect (or it does yet
  after a minute touchpad stops working for a moment and then switches
  to PS/2 in xinput). Multitouch stops working as well as tapping with
  two fingers.

  I tried almost all the possible workarounds involving adding boot
  options, installing elantech driver fixes etc.

  Help is appreciated.

  The output of xinput as for now:

  $ xinput
  ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer                      id=4    [slave  pointer 
  ⎜   ↳ PS/2 BYD TouchPad                               id=14   [slave  pointer 

     bustype : BUS_I8042
     vendor  : 0x2
     product : 0x1
     version : 99
     name    : "PS/2 BYD TouchPad"
     phys    : "isa0060/serio1/input0"
     bits ev : EV_SYN EV_KEY EV_REL


  Seems that forcing the psmouse to detect the touchpad as elantech
  helps to fix problem temporarily. But it works only from time to time:

  $ sudo rmmod psmouse
  $ sudo modprobe psmouse force="elantech"

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to