I had the same problem. Updating from 16.04 to 16.10 in place.

I ran boot-repair, but the tool had not been updated during the
migration (the update 16.10 removed the boot-repair ppa from the
sources.list). Running the repair completely botched my grub.cfg files
(update-grub was complaining about syntax errors). After a (painful)
manual restart through the grub command line, I was able to boot.

The I did:
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get upgrade

Using the new boot-repair (version 4ppa38, instead of the old 4ppa35), I
ran the repair tool, setup grub again, rebooted, and the "error: no
symbol table. Press any key to continue..." was gone.

People looking for a solution may update boot-repair to 4ppa38, run it,
and see if it fixes it. Make sure to backup your data first, it worked
for me but I can't guarantee that it will work for you.

I am attaching the boot-repair report done with 4ppa35, which may be of
interest for people trying to debug this.

** Attachment added: "boot-repair output"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  No symbol table. Press any key to continue

Status in linux package in Ubuntu:

Bug description:
  Ubuntu 16.10. shows "error: no symbol table. Press any key to
  continue..." after Kernel boot and before login screen. After pressing
  a key or waiting a few seconds, the boot process continues and login
  screen appears.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: linux-image-4.8.0-22-generic 4.8.0-22.24
  ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
  Uname: Linux 4.8.0-22-generic x86_64
  ApportVersion: 2.20.3-0ubuntu8
  Architecture: amd64
   /dev/snd/controlC0:  xxxx       7722 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Sun Oct 16 13:25:22 2016
  EcryptfsInUse: Yes
  HibernationDevice: RESUME=UUID=9d3bac9d-90f6-4fb6-ba39-e08ea2c3aa19
  InstallationDate: Installed on 2013-10-28 (1083 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 
  MachineType: LENOVO 23255B2
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-22-generic 
root=UUID=3b21f524-fe80-4ab0-8b84-c03e44abcd8b ro elevator=deadline
   linux-restricted-modules-4.8.0-22-generic N/A
   linux-backports-modules-4.8.0-22-generic  N/A
   linux-firmware                            1.161
  SourcePackage: linux
  UpgradeStatus: Upgraded to yakkety on 2016-10-16 (0 days ago)
  dmi.bios.date: 03/03/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G2ETA6WW (2.66 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 23255B2
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Defined
  dmi.chassis.asset.tag: CS0000023589
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.product.name: 23255B2
  dmi.product.version: ThinkPad X230
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to