** Tags removed: kernel-bug-exists-upstream-4.7-rc5
** Tags added: kernel-bug-exists-upstream-4.8

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  SHIFT, ALT and CTRL problem with HP pavilion 15 ab062nl

Status in linux package in Ubuntu:

Bug description:
  I've a problem with the keyboard of notebook HP Pavilion 15 ab062nl.
  the problem is with SHIFT ALT and CTRL buttons of the keyboard.

  for example when i use ALT-TAB shortcut, after few seconds, the ALT-TAB menu 
disappear as if i release ALT key, but isn't so.
  another example is when i navigate on web, when i scroll page with mouse 
wheel, sometimes the page start to resize, as if i'm pressing CTRL command 
while scroll, or if i'm writing a text, sometimes, borwser launch shortcut, as 
if i'm pressing CTRL while i type text, for exaple if i'm typing "b" letter, 
opens bookmarks...

  another example is while i'm typing text, if i press SHIFT key and
  start typing, begins to write uppercase letters and after a while,
  writes lowercase like I released shift, but i'm still pressing shift.

  for example if i press SHIFT+s, the result is this:
  some letters are uppercase, but others are lowercase.

  WORKAROUND: Use kernel parameter:

  the only way to solve momentarily the problem, is pressing for some
  seconds the only SHIFT key, after that, the problems disappears
  indefinitely, or until the next restart.

  This problem occurs with all ubuntu version (x86 and x86_64), now i'm
  using Ubuntu 15.10, but i've also tried ubuntu 15.04, ubuntu 14.04,
  ubuntu 12.04, ubuntu 10.04.

  furthermore i've this problem also with other GNU/Linux Distributions (i've 
tried Fedora, OpenSuse, ArchLinux, Antergos, Debian, SteamOS).
  but isn't and hardware problem, because on Windows 8.1 and Windows 10 i 
haven't these problems.

  i've also tried to plug in an externa USB keyboard, and if i use
  external USB keybaord i haven't problems.

  i think is a problem of compatibility, with integrated keyboard of
  this notebook.

  i've tried to monitor these problems using XEV, and the results is
  that also if i'm not using notebook, sometimes XEV reads an INPUT of
  one of these 3 key (SHIFT, ALT, CTRL), and while i'm pressing one of
  these 3 key, XEV see also if i release and immedialty after press
  again the key.

  this is an example of the input while i press Left_ALT key for a while

  KeyPress event, serial 37, synthetic NO, window 0x3e00001,
      root 0x498, subw 0x0, time 129987, (-142,152), root:(452,476),
      state 0x10, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
      XLookupString gives 0 bytes:
      XmbLookupString gives 0 bytes:
      XFilterEvent returns: False

  KeyRelease event, serial 37, synthetic NO, window 0x3e00001,
      root 0x498, subw 0x0, time 130147, (-142,152), root:(452,476),
      state 0x18, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
      XLookupString gives 0 bytes:
      XFilterEvent returns: False

  KeyPress event, serial 37, synthetic NO, window 0x3e00001,
      root 0x498, subw 0x0, time 130391, (-142,152), root:(452,476),
      state 0x10, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
      XLookupString gives 0 bytes:
      XmbLookupString gives 0 bytes:
      XFilterEvent returns: False

  whole log here http://pastebin.com/CPGz40aw

  and this is the output of xev, leaving the notebook on a few hours
  without using it http://pastebin.com/sYSHAbGy

  this is "xinput" output

  ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer                      id=4    [slave  pointer 
  ⎜   ↳ Logitech USB Laser Mouse                        id=11   [slave  pointer 
  ⎜   ↳ SynPS/2 Synaptics TouchPad                      id=13   [slave  pointer 
  ⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
      ↳ Virtual core XTEST keyboard                     id=5    [slave  
keyboard (3)]
      ↳ Power Button                                    id=6    [slave  
keyboard (3)]
      ↳ Video Bus                                       id=7    [slave  
keyboard (3)]
      ↳ Video Bus                                       id=8    [slave  
keyboard (3)]
      ↳ Power Button                                    id=9    [slave  
keyboard (3)]
      ↳ HP Truevision HD                                id=10   [slave  
keyboard (3)]
      ↳ AT Translated Set 2 keyboard                    id=12   [slave  
keyboard (3)]
      ↳ HP WMI hotkeys                                  id=14   [slave  
keyboard (3)]
      ↳ HP Wireless hotkeys                             id=15   [slave  
keyboard (3)]

  i hope that this bug can be solved

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-16-generic 4.2.0-16.19
  ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
  Uname: Linux 4.2.0-16-generic x86_64
  ApportVersion: 2.19.1-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC1:  ubuntu     1980 F.... pulseaudio
   /dev/snd/controlC0:  ubuntu     1980 F.... pulseaudio
  CasperVersion: 1.365
  CurrentDesktop: Unity
  Date: Mon Jan 11 10:08:12 2016
  LiveMediaBuild: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: Hewlett-Packard HP Pavilion Notebook
   PATH=(custom, no user)
  ProcFB: 0 amdgpudrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi 
file=/cdrom/preseed/username.seed boot=casper quiet splash ---
   linux-restricted-modules-4.2.0-16-generic N/A
   linux-backports-modules-4.2.0-16-generic  N/A
   linux-firmware                            1.149
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/06/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F.13
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 80B5
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 81.28
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: Chassis Version
  dmi.product.name: HP Pavilion Notebook
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to