Abalan, you're subscribed to the "linux in Ubuntu" package, which is why
you're receiving bug reports:


You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Power S822LC (8335-GTB) failes KVM guest cert test with kvm_init_vcpu
  failed: Invalid argument

Status in linux package in Ubuntu:
Status in linux source package in Xenial:

Bug description:
  Upon running the virtualization test from the certification test
  suite, the kvm guest test fails with the following error:

  kvm_init_vcpu failed: Invalid argument

  This same test works on multiple other IBM Power 8 and Openpower
  servers. kvm-ok tells us that kvm virtualization is supported. I have
  tried with SMT enabled and disabled. I have tried the latest cloud
  image as well as previous onces we had saved. I have tried running the
  qemu-system-ppc64 command found below manually with the same error.

  The full output from the test is as follows:

  Executing KVM Test
  DEBUG:root:Starting KVM Test
  DEBUG:root:Cloud image location specified:
  DEBUG:root:Downloading xenial-server-cloudimg-ppc64el-disk1.img, from
  DEBUG:root:Creating cloud user-data
  DEBUG:root:Creating cloud meta-data
  I: -input-charset not specified, using utf-8 (detected in locale settings)
  Total translation table size: 0
  Total rockridge attributes bytes: 331
  Total directory bytes: 0
  Path table size(bytes): 10
  Max brk space used 0
  183 extents written (0 MB)
  DEBUG:root:Attempting boot for:xenial-server-cloudimg-ppc64el-disk1.img
  DEBUG:root:Attaching Cloud config disk
  DEBUG:root:Using params:qemu-system-ppc64 -m 1024 -display none -nographic 
-net nic -net user,net=,host=,hostfwd=tcp::2222-:22 
-enable-kvm -machine pseries,usb=off -cpu POWER8 -drive 
file=xenial-server-cloudimg-ppc64el-disk1.img,if=virtio -drive 
  INFO:root:Storing VM console output in 

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-59-generic 4.4.0-59.80
  ProcVersionSignature: Ubuntu 4.4.0-59.80-generic 4.4.35
  Uname: Linux 4.4.0-59-generic ppc64le
   total 0
   crw-rw---- 1 root audio 116,  1 Jan 12 22:18 seq
   crw-rw---- 1 root audio 116, 33 Jan 12 22:18 timer
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.20.1-0ubuntu2.4
  Architecture: ppc64el
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  Date: Thu Jan 12 22:45:34 2017
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
   Bus 002 Device 002: ID 125f:312b A-DATA Technology Co., Ltd. Superior S102 
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 046b:ff10 American Megatrends, Inc. Virtual Keyboard 
and Mouse
   Bus 001 Device 002: ID 046b:ff01 American Megatrends, Inc. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   PATH=(custom, no user)
  ProcFB: 0 astdrmfb
  ProcKernelCmdLine: root=UUID=a7ce18b4-4614-485f-9346-b19b0415db3a ro fips=1
  ProcLoadAvg: 0.03 0.02 0.08 1/1288 11017
   1: POSIX  ADVISORY  WRITE 3709 00:14:665 0 EOF
   2: POSIX  ADVISORY  WRITE 3593 00:14:655 0 EOF
   3: POSIX  ADVISORY  WRITE 1658 00:14:376 0 EOF
   4: FLOCK  ADVISORY  WRITE 3560 00:14:637 0 EOF
   5: POSIX  ADVISORY  WRITE 3571 00:14:640 0 EOF
   Filename                             Type            Size    Used    Priority
   /swap.img                               file         8388544 0       -1
  ProcVersion: Linux version 4.4.0-59-generic (buildd@bos01-ppc64el-029) (gcc 
version 5.4.0 20160609 (Ubuntu/IBM 5.4.0-6ubuntu1~16.04.4) ) #80-Ubuntu SMP Fri 
Jan 6 17:35:59 UTC 2017
   linux-restricted-modules-4.4.0-59-generic N/A
   linux-backports-modules-4.4.0-59-generic  N/A
   linux-firmware                            1.157.6
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  cpu_cores: Number of cores present = 20
  cpu_coreson: Number of cores online = 20
  cpu_dscr: DSCR is 0
   min: 3.959 GHz (cpu 79)
   max: 3.988 GHz (cpu 81)
   avg: 3.974 GHz
   Could not retrieve current diagnostics mode,
   No kernel interface to firmware
  cpu_smt: SMT=8

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to