@Robert ... sure, let me clarify the events.

1. I had Ubuntu 16.04 LTS for some time already running on my system.
2. I bought AMD Ryzen 1800 + Gigabyte AB350 Gaming 3 and I took the SSD from 
the old system and pushed it into the new one
3. Everything worked fine, except I had to install NVIDIA drivers (I also 
bought a better video card)
4. I noticed I couldn`t get CPU temperature, so I tried my luck by upgrading to 
----> during OS boot the IRQ VECTOR 07 error is repeated over and over
5. I then downloaded the 17.04 on a disk, and tried to install it 
----> ended up with IRQ VECTOR 07 error during install (so, no go)
6. I tried the Ubuntu 16.04 LTS from a disk (which was the origin of the OS at 
step 1 ...) --> worked fine
7. I installed Ubuntu 16.04 LTS and here I am .. back at step 3 :)

I`ve never installed STUDIO, only DESKTOP as in this :

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  System doesn't boot properly on AMD Ryzen / Gigabyte GA-AB350-gaming-3

Status in linux package in Ubuntu:

Bug description:
  I'm trying to run ubuntu on Ryzen 1700x with Gigabyte GA-AB350-gaming-3 
  and it has a load of problems, starting with not being able to boot normally.

  During normal boot, on 16.10 as well as 17.04 beta:
  system doesn't boot normally, hangs with a lot of "unexpected irq trap at 
vector 07"
  messages displayed.

  Following advice from various places, I've tried:disable cpu freq governor 
and cpu handling in acpi settings

  1. add "acpi=off" to boot params

  That helps, allowing me to boot into recovery mode, though it leaves
  me with system seeing only one core, is really slow and still only
  boots in recovery mode.

  2. Compile own kernel using 4.11.rc1 and disabling cpu freq governor
  and cpu handling in acpi settings. Boot with "quiet loglevel=3"

  That gets me even further - system sees all cores now. Still only recovery 
mode though,
  but its enough to get info for this bug report.

  Some observed problems:

  1. dmesg reports *a lot* of messages like this all the time:

  [  163.362068] ->handle_irq():  ffffffff87a7e090, 
  [  163.362081] bad_chained_irq+0x0/0x40
  [  163.362089] ->handle_irq():  ffffffff87a7e090, 
  [  163.362090] amd_gpio_irq_handler+0x0/0x200
  [  163.362090] ->irq_data.chip(): ffffffff88587e20, 
  [  163.362090] ioapic_ir_chip+0x0/0x120
  [  163.362090] ->action(): ffffffff884601c0
  [  163.362091]    IRQ_NOPROBE set
  [  163.362099] ->handle_irq():  ffffffff87a7e090, 
  [  163.362099] amd_gpio_irq_handler+0x0/0x200
  [  163.362100] ->irq_data.chip(): ffffffff88587e20, 
  [  163.362100] ioapic_ir_chip+0x0/0x120
  [  163.362101] ->action(): ffffffff884601c0

  I've tried to redirect dmesg to a file, stopped after a short while,
  it generated 400M of those.

  2. Systemd cannot start journald. Perhaps because it cannot cope with
  amount of kernel logs?

  3. Looking at pci, I've noticed something called AMDI0040
  (/sys/bus/acpi/devices/AMDI0040, path=_SB_.EMMC), among AMDI0010,
  AMDI0020, AMDI0030. Those however are mentioned in kernel source,
  kernel and google are completely silent about AMDI0040.

  Phoronix tested ryzen using different motherboard, and it worked better 
(though not well),
  so I suspect it is an issue with motherboard.
  ApportVersion: 2.20.4-0ubuntu2
  Architecture: amd64
  DistroRelease: Ubuntu 17.04
  InstallationDate: Installed on 2015-08-06 (581 days ago)
  InstallationMedia: Kubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150728.1)
  Package: linux (not installed)
   PATH=(custom, no user)
  Tags:  zesty
  Uname: Linux 4.11.0-rc1-custom x86_64
  UnreportableReason: The running kernel is not an Ubuntu kernel
  UpgradeStatus: Upgraded to zesty on 2017-03-03 (6 days ago)
  _MarkForUpload: True

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to