Specifically, the 4.13.0-25 dbgsym package is available from here:
https://launchpad.net/~canonical-kernel-security-team/+archive/ubuntu/ppa/+build/14223090

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1744791

Title:
  [Ubuntu18.04] linux-image-4.13.0-25-generic-dbgsym is not available in
  repo which is required for crash analysis of vmcore

Status in The Ubuntu-power-systems project:
  Triaged
Status in linux package in Ubuntu:
  In Progress

Bug description:
  ---Problem Description---
  No debug kernel deb packages available for 4.13.0-25-generic kernel [Ubuntu 
18.04 ]
  Unable to analyze vmcore generated via crash. 
    
  ---uname output---
  Linux spoon2 4.13.0-25-generic #29-Ubuntu SMP Mon Jan 8 21:15:55 UTC 2018 
ppc64le ppc64le ppc64le GNU/Linux
   
  Machine Type = 8335-GTC 
   
  ---Steps to Reproduce---
  Install 18.04 ppc64el
  upgrade kernel to 4.13.0-25-generic or 4.13.0-17-generic
  try configuring debug repo
  https://wiki.ubuntu.com/Kernel/CrashdumpRecipe
  http://ddebs.ubuntu.com/pool/main/l/linux/
  sudo tee /etc/apt/sources.list.d/ddebs.list << EOF
  deb http://ddebs.ubuntu.com/ $(lsb_release -cs)          main restricted 
universe multiverse
  deb http://ddebs.ubuntu.com/ $(lsb_release -cs)-security main restricted 
universe multiverse
  deb http://ddebs.ubuntu.com/ $(lsb_release -cs)-updates  main restricted 
universe multiverse
  deb http://ddebs.ubuntu.com/ $(lsb_release -cs)-proposed main restricted 
universe multiverse
  EOF

  sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys ECDCAD72428D7C01
  sudo apt-get update
  sudo apt-get install linux-image-$(uname -r)-dbgsym

  Warning /!\ Be aware that those packages are huge! (~600 MB)

  When installed, the debug kernel can be found under
  /usr/lib/debug/boot/ and crash is started by:

  crash <debug kernel> <crash dump>

  Crash command to analyze vmcore will not work as kernel debuginfo deb package 
is not found in repo . 
  root@spoon2:~# sudo apt-get install linux-image-$(uname -r)-dbgsym
  Reading package lists... Done
  Building dependency tree       
  Reading state information... Done
  E: Unable to locate package linux-image-4.13.0-25-generic-dbgsym
  E: Couldn't find any package by glob 'linux-image-4.13.0-25-generic-dbgsym'
  E: Couldn't find any package by regex 'linux-image-4.13.0-25-generic-dbgsym'
  root@spoon2:~# 
   
  I was also not able to find this debug symbol for 18.04 kernel. I understand 
that the current 18.04 kernel is old and was removed from the archive. Is it 
correct?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-power-systems/+bug/1744791/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to