I'm sorry that I confused with the IGMP service with the PIM service on
Dell FTOS 9, which printed the debugging message "Invalid sender

and I think you can just test the igmp connection by issuing "ping" instead of installing quagga and launching pimd.

Best regards,

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  incorrect source address in IGMP Membership Report messages

Status in linux package in Ubuntu:

Bug description:
  I found that linux kernel had had a bug in the implementation of IGMP
  membership report packet generation. the RFC documents for IGMP version 2
  and 3 says that you must ignore the reports with a source ip address that
  you can't identify as belonging to a network assigned to the interface on
  which the packet was received. and the networking OS in the ToR switch,
  Force10 OS 9 does ignore it.

  I've also figured out a patch has been made for this bug in Linus's Github.
  and there was a mark on Github that reads "v4.16-rc1". (

  I honestly have no idea how Ubuntu LTS team works with regard to this kind
  of patches from the fresh new upstream version of linux kernel. hope you
  guys will easily fix it for people like me who has no experience at
  building and distributing custom built kernels over a few servers.

  Test environment:
  I used two ToR switches and one linux machine for this test.
  I only used 2 ethernet ports on the linux machine.
  There was a recent version of Ubuntu with HWE kernel. I'm not sure if
  no-HWE one would be the same case - the version of linux-generic-hwe-16.04
  was -
  To test networking router stuff, I used the quagga from Cumulus Routing on
  the Host 3.3.2 (

  What I did and saw in my case:
  1. set a network interface (A) so it gets an IPv4 address, but also in vain
  issue "ip link set ${if_name} multicast off"
  2. assign an IPv4 address to another network interface (B), but in this
  case with a 31-bit-long subnet mask length.
  3. install quagga from cumulus, launch zebra and pimd, issue "ip pim sm" in
  the interface configuration mode for the interface (B) with a 31-bit-long
  subnet mask length
  4. I checked that the source IP address part of the IGMP membership report
  packets from the linux machine is the address I assigned to the network
  interface (A) with 27-bit-long subnet mask -using dumpcap and tshark-, and
  that the PIM service on the switch ignored the Reports printing debugging
  messages including : "Invalid sender address"

   affects ubuntu

  You can find my PGP public key here: https://google.com/+DewrKim/about

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to