LGTM to artful-proposed:

15: gre_sys@NONE: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 65000 qdisc pfifo_fast 
master ovs-system state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether 92:92:4d:84:14:1d brd ff:ff:ff:ff:ff:ff

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 17.10
Release:        17.10
Codename:       artful

$ uname -a
Linux juju-9b0cd0-artful-proposed-19 4.13.0-35-generic #39-Ubuntu SMP Mon Feb 
12 11:06:39 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


** Tags removed: verification-needed-artful
** Tags added: verification-done-artful

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1743746

Title:
  4.13: unable to increase MTU configuration for GRE devices

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Artful:
  Fix Committed
Status in linux source package in Bionic:
  Fix Committed

Bug description:
  [Impact]
  GRE overlay networks can't carry traffic with MTU > 1500

  [Test Case]
  sudo add-apt-repository cloud-archive:pike
  sudo apt update
  sudo apt install openvswitch-switch
  sudo ovs-vsctl add-br br-tun
  sudo ovs-vsctl add-port br-tun gre0 -- set interface gre0 type=gre 
options:remote_ip=10.100.1.1

  gre_sys device will be configured with MTU 1472.

  sudo ip link set gre_sys mtu 65000

  will fail with EINVAL.

  [Regression Potential]

  [Bug Report]

  Under Linux 4.13 its not possible to configure GRE tunnel devices with
  a MTU larger than 1500; this impacts on Open vSwitch (which creates
  tunnel devices for GRE overlay networking) and the ip tools.

  The kernel will error with:

    gre_sys: Invalid MTU 65000 requested, hw max 1500

  The side effect of this is that if overlay networks are configured
  with high MTUs, the gre devices fragment the packets and networking is
  generally slow/broken.

  This is resolved as part of the upcoming 4.15 kernel under:

  
https://github.com/torvalds/linux/commit/cfddd4c33c254954927942599d299b3865743146

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1743746/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to