Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: linux (Ubuntu Artful)
       Status: New => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Dell XPS 13 9360 bluetooth (Atheros) won't connect after resume

Status in linux package in Ubuntu:
Status in linux source package in Artful:

Bug description:
  === SRU Justification ===
  Bluetooth (Atheros) won't connect after resume.

  [Test Case]
  Suspend/resume XPS 9360. BT controller is not functional now.
  With the fix, user confirms the issue is fixed.

  [Regression Potential]
  Low. Limited to Atheros BT. No regression report so far since Hans'
  patch got merged upstream.

  === Original Bug Report ===

  Sometimes after sleep/resume bluetooth won't reconnect to any device.

  I can see this in dmesg:
  [13129.890580] Bluetooth: hci0 command 0x0c1a tx timeout

  I tried:
  1. sudo hciconfig hci0 reset
  Can't init device hci0: Connection timed out (110)

  2. tried reloading modules:
  sudo rmmod btusb
  sudo rmmod btrtl
  sudo rmmod hci_uart
  sudo rmmod btintel
  sudo rmmod btbcm btqca
  sudo rmmod rfcomm

  sleep 1

  sudo modprobe btusb btrtl hci_uart btintel btbcm btqca rfcomm

  no luck.

  3. restart bluetoothd - no luck

  Only reboot helps.

  Laptop is: Dell XPS 13 9360.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: bluetooth (not installed)
  ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
  Uname: Linux 4.13.0-25-generic x86_64
  ApportVersion: 2.20.7-0ubuntu3.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Jan 22 12:50:58 2018
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2017-12-18 (35 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: Dell Inc. XPS 13 9360
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-25-generic.efi.signed 
root=UUID=e20224ee-6bcd-49a5-b911-a0c129a48da5 ro quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: No upgrade log present (probably fresh install) 12/12/2017
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 2.5.0 02PG84
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
dmi:bvnDellInc.:bvr2.5.0:bd12/12/2017:svnDellInc.:pnXPS139360:pvr:rvnDellInc.:rn02PG84:rvrA00:cvnDellInc.:ct9:cvr: XPS XPS 13 9360
  dmi.sys.vendor: Dell Inc.
   hci0:        Type: Primary  Bus: USB
    BD Address: 9C:B6:D0:EB:95:A6  ACL MTU: 1024:8  SCO MTU: 50:8
    RX bytes:2301887 acl:127559 sco:0 events:249 errors:0
    TX bytes:4327 acl:47 sco:0 commands:81 errors:0

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to