I can't test the touchpad on 4.16, since it wont get up from suspend state. 
Tried it on 4.16-rc1 and 4.16-rc2 and it was the same. Resume from suspend 
worked on 4.15 but not on 4.16 and also on 4.15-rc9 i was able to get a 
half-working (cursor movement/tap, but no left/right buttons) touchpad after 
resuming the notebook from suspend.
My device is a Chuwi Lapbook Air.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Touchpad stops working after reboot on Apollo Lake

Status in Linux:
Status in linux package in Ubuntu:

Bug description:
  On the Jumper EZBook 3 Pro (V4) laptop, using an Apollo Lake N3450
  processor, if you install Ubuntu 17.10 (or less) with isorespin and
  use rEFInd as bootloader (this is the only way to get linux booting on
  this laptop) everything works out of the box, but after a reboot or
  two the touchpad stops working. Both in Ubuntu and Windows 10. The
  only way to restore functionality is to boot from usb key ubuntu 17.10
  respined, or disassemble laptop and detach-reattach battery cable.
  This is mesg | grep i2c_hid:

  [ 2056.460636] i2c_hid i2c-SYNA3602:00: i2c_hid_get_input: incomplete report 
  [ 3077.604699] i2c_hid i2c-SYNA3602:00: failed to reset device.
  [ 3077.605473] dpm_run_callback(): i2c_hid_resume+0x0/0xe0 [i2c_hid] returns 
  [ 3080.468156] i2c_hid i2c-SYNA3602:00: i2c_hid_get_input: incomplete report 

  uname -rvps
  Linux 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:19:02 UTC 2017 

  There has to be a bug in the kernel. Any way to avoid this?

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to