I keep experiencing this issue, using Ubuntu 17.10, an Intel Core
i3-5005U (with Intel HD 5500). It appears most often when a new
notification comes in (Slack/Spotify) and the lockscreen is visible.

>From dmesg:
[Fri Feb 23 13:51:50 2018] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] 
*ERROR* CPU pipe A FIFO underrun

$ uname -a
Linux uk-it-033 4.13.0-36-generic #40-Ubuntu SMP Fri Feb 16 20:07:48 UTC 2018 
x86_64 x86_64 x86_64 GNU/Linux

If you need any further information, please let me know.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1550779

Title:
  [i915]] *ERROR* CPU pipe A FIFO underrun - Xorg glitches

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  Upgraded linux-image-extra-4.2.0-30-generic I see graphic glitches,
  looks like the graphic buffer gets screwed up

  - funny repetition's patterns  (back in time glitches)
  - black screen (<1sec)
  - graphic errors  

  I can influence the severity of the issue with switching windows and
  using certain programs, e.g. Google Maps in chrome causes this issue
  reproducibly

  dmesg  | grep i915
  [    2.726864] [drm] Initialized i915 1.6.0 20150522 for 0000:00:02.0 on 
minor 0
  [    2.792005] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit 
banging on pin 5
  [    3.471092] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
  [    3.471093] i915 0000:00:02.0: registered panic notifier
  [    9.573129] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU 
pipe A FIFO underrun
  [    9.574847] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* 
uncleared pch fifo underrun on pch transcoder A
  [    9.574895] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH 
transcoder A FIFO underrun

  linux-image-extra-4.2.0-27-generic works find

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: xorg 1:7.7+7ubuntu4
  ProcVersionSignature: Ubuntu 4.2.0-30.36-generic 4.2.8-ckt3
  Uname: Linux 4.2.0-30-generic x86_64
  .tmp.unity.support.test.0:
   
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  BootLog:
   
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: GNOME
  Date: Sat Feb 27 20:26:07 2016
  DistUpgraded: Fresh install
  DistroCodename: wily
  DistroVariant: ubuntu
  DkmsStatus:
   virtualbox, 5.0.14, 4.2.0-27-generic, x86_64: installed
   virtualbox, 5.0.14, 4.2.0-30-generic, x86_64: installed
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics 
Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
     Subsystem: Lenovo Device [17aa:21da]
  InstallationDate: Installed on 2016-02-11 (15 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: LENOVO 42912XG
  ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-4.2.0-30-generic 
root=UUID=cb34d7bb-9316-49b3-aa94-4e2a3512168f ro rootflags=subvol=@ noprompt 
quiet
  SourcePackage: xorg
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/18/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8DET69WW (1.39 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 42912XG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr8DET69WW(1.39):bd07/18/2013:svnLENOVO:pn42912XG:pvrThinkPadX220:rvnLENOVO:rn42912XG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 42912XG
  dmi.product.version: ThinkPad X220
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:0.9.12.2+15.10.20151202-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.64-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
  version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 
1:7.5.0+git20150819-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20150808-0ubuntu4
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.11-1ubuntu3
  xserver.bootTime: Sat Feb 27 20:25:23 2016
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id                               12359 
   vendor                                     SEC
  xserver.version: 2:1.17.2-1ubuntu9.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1550779/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to