5520 native resolution is 2160p, 9560 is 1080p. Both are configured to
run 1080p through GNOME settings.

I will try out Bionic tonight or latest Monday - don't have it at hand
at the moment.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  TB16 dock freezes X on hotplug when used with external displays

Status in Dell Sputnik:
Status in linux package in Ubuntu:

Bug description:
  Precision 5520 with Quadro GPU. Latest Ubuntu 16.04, kernel Linux
  REDACTED 4.13.0-36-generic #40~16.04.1-Ubuntu SMP Fri Feb 16 23:25:58
  UTC 2018 x86_64 x86_64 x86_64 GNU/Linux, latest BIOS 1.7.0 released
  12/15/2017. If it can be of any help, I can get this tested on an XPS
  9560 (GTX 1050) too.

  Steps to reproduce:

  1. Plug in monitors into DP and miniDP on the dock. In my case, DP-to-DVI 
cables are used, but I doubt that it matters.
  2. Ubuntu 16.04 GNOME + nVidia drivers with PRIME.
  3. Select nVidia GPU in PRIME settings, reboot if needed.
  4. Either boot with the dock connected or connect it after booting into user 
  5. Set up monitors if necessary. At this point everything should be working 
  6. Disconnect the dock, give it a moment to adjust to the new window layout 
  7. Re-connect the dock. Within a few seconds laptop screen should freeze and 
external monitors should remain blank, as if not connected.
  8. Disconnect the dock. Within a few seconds laptop screen should unfreeze. 
There is a small chance that it won't if you repeat this procedure multiple 

  Errors in dmesg indicate that i915 driver is somehow involved:

  [  328.966128] [drm:intel_dp_set_idle_link_train [i915]] *ERROR* Timed out 
waiting for DP idle patterns
  [  328.967848] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting 
for DDI BUF B idle bit
  [  329.048839] [drm:intel_dp_set_idle_link_train [i915]] *ERROR* Timed out 
waiting for DP idle patterns
  [  329.050547] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting 
for DDI BUF C idle bit

  The kernel logs are flooded with these between steps 7 and 8 above.

  This behaviour does not occur when Intel GPU is selected in PRIME
  settings or when nouveau is used. However, nouveau performance leaves
  a lot to be desired, particularly with 3D acceleration in Windows 10

  I have tried nvidia_drm.modeset=1 in boot options, but it doesn't make
  any difference.

  Other reports that may be related:

  hangs-the-whole-machine/ - same error messages

  - "Connecting and disconnecting the TB16 sometimes freeze the laptop."

 - "Hot-plugging the screen does not work."
  ApportVersion: 2.20.1-0ubuntu2.15
  Architecture: amd64
   /dev/snd/controlC0:  gboiko     2491 F.... pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.04
  HibernationDevice: RESUME=UUID=08bba264-8658-442f-995d-6a745925ac6c
  InstallationDate: Installed on 2017-10-01 (149 days ago)
  InstallationMedia: Ubuntu-GNOME 16.04.3 LTS "Xenial Xerus" - Release amd64 
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 04f3:24a1 Elan Microelectronics Corp. 
   Bus 001 Device 002: ID 8087:0a2b Intel Corp. 
   Bus 001 Device 004: ID 1bcf:2b95 Sunplus Innovation Technology Inc. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. Precision 5520
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-36-generic 
root=/dev/mapper/ubuntu--gnome--vg-root ro ipv6.disable=1 net.ifnames=0 
biosdevname=0 nvidia_drm.modeset=1 quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.13.0-36.40~16.04.1-generic 4.13.13
   linux-restricted-modules-4.13.0-36-generic N/A
   linux-backports-modules-4.13.0-36-generic  N/A
   linux-firmware                             1.170
  Tags:  xenial
  Uname: Linux 4.13.0-36-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 12/15/2017
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.7.0
  dmi.board.name: 0R6JFH
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.product.family: Precision
  dmi.product.name: Precision 5520
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to