This bug seems to be the closest match to what I'm experiencing. I'm
hitting similar trouble on desktop/graphical Ubuntu on some Dell

Ubuntu 16.04 AMD64.

Happening on kernel versions 4.13.0-38 and 4.4.0-116.

I've tried version 4.4.0-117 as posted by @kamalmostafa - same result.

The laptops are an XPS 13 and a Precision M3520. Both machines have Kaby
Lake/7th gen Core i7 CPUs.

The problem on the 4.4.0-116 kernel (on my M3520) occurred the first
reboot after updating the Intel microcode. I'm starting to think this is
related to the Meltdown/Spectre patching.

I started sssd in the foreground with debug set to 9 on the M3520 and
netcat'd the results to another machine, so I think I have it right up
until the laptop stops responding. It's obviously quite verbose, but if
someone thinks it'll help, I'll post it.

>From talking to some of the people on #ubuntu-server, the microcode does
seem to be increasingly likely the root cause. Bug #1759920 may include
relevant information.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  sssd appears to crash AWS c5 and m5 instances, cause 100% CPU

Status in cloud-images:
  Fix Released
Status in linux package in Ubuntu:
  In Progress
Status in linux-aws package in Ubuntu:
Status in linux source package in Xenial:
  In Progress
Status in linux-aws source package in Xenial:
  In Progress

Bug description:
  After upgrading to the Ubuntu EC2 AMI from 20180126 (specifically
  ami-79873901 in us-west-2) we have seen sssd hard locking c5 and m5
  EC2 instances after starting the service and CPU goes to 100%.

  We do not experience this issue with t2 or c4 instance types and we do
  not see this issue on any instance types using Ubuntu Cloud images
  from 20180109 or before. I have verified that this is kernel related
  as I booted an image that we created using the Ubuntu cloud image from
  20180109 which works fine on a c5. I then did a "apt update && apt
  install --only-upgrade linux-aws && systemctl disable sssd", rebooted
  the server, verified I was on the new kernel and started sssd with
  "systemctl start sssd" and the EC2 instance froze and Cloudwatch CPU
  usage for that instance went to 100%.

  I haven't been able to find much in the syslog, kern.log, journalctl
  logs, etc. The only thing I have been able to find is that when this
  happens I tend to see "^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@" in
  the syslog and sssd log files.  I have attached several log files and
  the output of a "apport-bug /usr/sbin/sssd". Let me know if you need
  anything else to help track this down.


To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to