Yes I did run with sudo. The error message is different without sudo. I
think the new 14.04.5 fixed a lot of problems with the new intel cpu. At
least it fixed all my graphics card driver issue in one shot. However,
how do I find out what is supported with intel-gpu-tools?

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to intel-gpu-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1752194

Title:
  Intel GPU tools crash with "Couldn't map MMIO region"

Status in intel-gpu-tools package in Ubuntu:
  New

Bug description:
  Trying to run anything in intel-gpu-tools (tested intel_gpu_top, 
intel_gpu_time and intel_backlight) on my laptop (which has hybrid graphics, 
GTX 760m (proprietary nvidia driver not installed right now) + Intel 4th gen 
iGPU) as root yields the following output:
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Test assertion failure function 
intel_mmio_use_pci_bar, file ../../lib/intel_mmio.c:145:
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Failed assertion: !(error != 0)
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Last errno: 1, Operation not 
permitted
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Couldn't map MMIO region
  Stack trace:
    #0 [_init+0x1753f]
    #1 [_init+0xc978]
    #2 [_init+0x118d]
    #3 [__libc_start_main+0xf1]
    #4 [_init+0x1fba]
    #5 [<unknown>+0x1fba]
  Test (null) failed.
  **** DEBUG ****
  (intel_gpu_top:23021) intel-chipset-DEBUG: Test requirement passed: pci_dev
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Test assertion failure function 
intel_mmio_use_pci_bar, file ../../lib/intel_mmio.c:145:
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Failed assertion: !(error != 0)
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Last errno: 1, Operation not 
permitted
  (intel_gpu_top:23021) intel-mmio-CRITICAL: Couldn't map MMIO region
  (intel_gpu_top:23021) igt-core-INFO: Stack trace:
  (intel_gpu_top:23021) igt-core-INFO:   #0 [_init+0x1753f]
  (intel_gpu_top:23021) igt-core-INFO:   #1 [_init+0xc978]
  (intel_gpu_top:23021) igt-core-INFO:   #2 [_init+0x118d]
  (intel_gpu_top:23021) igt-core-INFO:   #3 [__libc_start_main+0xf1]
  (intel_gpu_top:23021) igt-core-INFO:   #4 [_init+0x1fba]
  (intel_gpu_top:23021) igt-core-INFO:   #5 [<unknown>+0x1fba]
  ****  END  ****
  FAIL (-1.000s)

  Happens under bot Wayland and XOrg.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: intel-gpu-tools 1.20-1ubuntu1
  ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
  Uname: Linux 4.13.0-32-generic x86_64
  ApportVersion: 2.20.7-0ubuntu3.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Feb 28 00:30:15 2018
  InstallationDate: Installed on 2015-11-25 (825 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  SourcePackage: intel-gpu-tools
  UpgradeStatus: Upgraded to artful on 2017-11-01 (118 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/intel-gpu-tools/+bug/1752194/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to