I think the real fix is easier... This still has two copies of the file:

sarnold@hunt:/tmp/bolt$ ar x thunderbolt-tools_0.9.3-2_amd64.deb 
sarnold@hunt:/tmp/bolt$ tar tf data.tar.xz 
./
./lib/
./lib/udev/
./lib/udev/rules.d/
./lib/udev/rules.d/60-tbtacl.rules
./lib/udev/rules.d/60-tbtxdomain.rules
./lib/udev/rules.d/tbtacl.rules
./lib/udev/tbtacl
./lib/udev/tbtacl-write
./lib/udev/tbtxdomain
./usr/
./usr/bin/
./usr/bin/tbtadm
./usr/share/
./usr/share/bash-completion/
./usr/share/bash-completion/completions/
./usr/share/bash-completion/completions/tbtadm
./usr/share/doc/
./usr/share/doc/thunderbolt-tools/
./usr/share/doc/thunderbolt-tools/changelog.Debian.gz
./usr/share/doc/thunderbolt-tools/copyright
./usr/share/doc/thunderbolt-user-space/
./usr/share/doc/thunderbolt-user-space/copyright
./usr/share/man/
./usr/share/man/man1/
./usr/share/man/man1/tbtadm.1.gz
sarnold@hunt:/tmp/bolt$ tar xf data.tar.xz 
sarnold@hunt:/tmp/bolt$ cat lib/udev/rules.d/*tbtacl*
# Thunderbolt udev rules for ACL (device auto approval)
SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="add"    
ATTR{authorized}=="0" RUN+="/lib/udev/tbtacl add    $devpath"
SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="change" 
ATTR{authorized}!="0" RUN+="/lib/udev/tbtacl change $devpath"
# Thunderbolt udev rules for ACL (device auto approval)
SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="add"    
ATTR{authorized}=="0" RUN+="/lib/udev/tbtacl add    $devpath"
SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="change" 
ATTR{authorized}!="0" RUN+="/lib/udev/tbtacl change $devpath"


I think the better solution is to delete this line from debian/rules:

        cp tbtacl/tbtacl.rules.in tbtacl/tbtacl.rules

Thanks

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to thunderbolt-tools in Ubuntu.
Matching subscriptions: Kernel Packages
https://bugs.launchpad.net/bugs/1761757

Title:
  use correct path for tbtacl in udev rules

Status in thunderbolt-tools package in Ubuntu:
  Fix Released

Bug description:
  ./thunderbolt-tools_0.9.3-1_amd64/lib/udev/rules.d/tbtacl.rules:
  # Thunderbolt udev rules for ACL (device auto approval)
  SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="add" 
ATTR{authorized}=="0" RUN+="@UDEV_BIN_DIR@/tbtacl add $devpath"
  SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="change" 
ATTR{authorized}!="0" RUN+="@UDEV_BIN_DIR@/tbtacl change $devpath"

  should changed to fix up @UDEV_BIN_DIR@ to be:

  SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="add"    
ATTR{authorized}=="0" RUN+="/lib/udev/tbtacl add    $devpath"
  SUBSYSTEM=="thunderbolt" ENV{DEVTYPE}=="thunderbolt_device" ACTION=="change" 
ATTR{authorized}!="0" RUN+="/lib/udev/tbtacl change $devpath"

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/thunderbolt-tools/+bug/1761757/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to