Just did a fresh upgrade of Ubuntu Mate from Xenial to Bionic.  The
guest packages were installed on the Xenial system prior to upgrade.
During the upgrade the guest packages were upgraded, NOT removed.

However, on the upgraded system the virtualbox-guest-utils.service was
NOT started but could be started manually.

Thus the original bug reported on this number still applies, although
all the other issues found on the way seem to have been addressed.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to dkms in Ubuntu.
https://bugs.launchpad.net/bugs/1753430

Title:
  virtualbox-guest-utils.service not starting

Status in dkms package in Ubuntu:
  Fix Released

Bug description:
  I am trialing various flavours of Ubuntu in Virtualbox virtual
  machines - Xubuntu, Lubuntu, Ubuntu and Ubuntu Mate.  All version
  18.04, running on Kubuntu 17.10 host.  All set up identically as far
  as I can tell, with virtualbox-guest-dkms, virtualbox-guest-utils and
  virtualbox-guest-x11 installed in each guest.

  All work fine except that shared folders does not work in 2 of the
  VMs.  It works in Xubuntu, Ubuntu but not in Lubuntu and Ubuntu Mate.
  On investigation it appears that the virtualbox-guest-utils.service is
  not started automatically on the two versions not working.  If I start
  it manually everything is OK.

  Here is the status - 
  systemctl status virtualbox-guest-utils.service 
  ‚óŹ virtualbox-guest-utils.service - Virtualbox guest utils
     Loaded: loaded (/lib/systemd/system/virtualbox-guest-utils.service; 
enabled; vendor preset: enabled)
     Active: inactive (dead)

  Looking in journalctl there are no messages showing that the service
  tried to start and failed.  There is nothing.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: virtualbox-guest-utils 5.2.8-dfsg-2
  ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
  Uname: Linux 4.15.0-10-generic i686
  ApportVersion: 2.20.8-0ubuntu10
  Architecture: i386
  CurrentDesktop: LXDE
  Date: Mon Mar  5 09:53:02 2018
  InstallationDate: Installed on 2012-10-23 (1958 days ago)
  InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
  ProcEnviron:
   LANGUAGE=en_GB:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_GB.UTF-8
   SHELL=/bin/bash
  SourcePackage: virtualbox
  UpgradeStatus: Upgraded to bionic on 2018-03-04 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1753430/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to