This change was made by a bot.

** Changed in: linux (Ubuntu)
       Status: New => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  rmmod b43 hangs

Status in linux package in Ubuntu:

Bug description:
  I'm running Ubuntu on a Dell Inspiron 6400 with a 14e4:4328 "Dell
  Wireless 1500 Draft 802.11n WLAN Mini-Card". Running "rmmod b43"
  always hangs. So far I have only tried it while connected to a
  wireless network. I immediately disconnect from the wireless network,
  so it seems module removal does begin. But the rmmod process never
  finishes and is unkillable. The hang seems indefinite, and a normal
  reboot is not possible, the rapid ctrl-alt-del systemd emergency
  reboot is impossible, and only a Magic SysRq reboot works.

  This worked in Ubuntu 17.10, but always fails in Ubuntu 18.04.

  (I was unloading the module before suspend due to occasional problems
  after resume. I tracked this down when wondering why suspend was
  hanging. Even running the "rmmod b43" on its own without suspend
  happening causes the hang. Right now I disabled that automatic

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-13-generic 4.15.0-13.14
  ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
  Uname: Linux 4.15.0-13-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 
  ApportVersion: 2.20.9-0ubuntu4
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: Intel [HDA Intel], device 0: STAC9200 Analog [STAC9200 Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  bgjenero   1560 F.... pulseaudio
   Card hw:0 'Intel'/'HDA Intel at 0xefffc000 irq 24'
     Mixer name : 'SigmaTel STAC9200'
     Components : 'HDA:83847690,102801bd,00102201 
     Controls      : 22
     Simple ctrls  : 9
  CurrentDesktop: XFCE
  Date: Sat Apr 14 11:54:36 2018
  HibernationDevice: RESUME=UUID=46f322d9-a161-4e1f-8a08-432d79aeac18
  InstallationDate: Installed on 2012-01-19 (2277 days ago)
  InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: Dell Inc. MM061
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-13-generic 
root=UUID=54eeb2ee-ee10-4c6b-9c61-1b790e52fd1e ro resume=/dev/sda6 nopti
   linux-restricted-modules-4.15.0-13-generic N/A
   linux-backports-modules-4.15.0-13-generic  N/A
   linux-firmware                             1.173
   0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: Upgraded to bionic on 2018-03-11 (34 days ago) 06/13/2007
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A17 0XD720
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
dmi:bvnDellInc.:bvrA17:bd06/13/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0XD720:rvr:cvnDellInc.:ct8:cvr: MM061
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to