Since the config options listed in this bug is already in bionic  
(Ubuntu-4.15.0-15.16). Marking bionic as fix-released.
bionic$ find debian.master/config/ -type f | xargs grep -E 
"CONFIG_XFRM_OFFLOAD|CONFIG_INET_ESP_OFFLOAD|CONFIG_INET6_ESP_OFFLOAD|CONFIG_MLX5_ACCEL|CONFIG_MLX5_EN_IPSEC"
debian.master/config/config.common.ubuntu:CONFIG_INET6_ESP_OFFLOAD=m
debian.master/config/config.common.ubuntu:CONFIG_INET_ESP_OFFLOAD=m
debian.master/config/config.common.ubuntu:CONFIG_MLX5_ACCEL=y
debian.master/config/config.common.ubuntu:CONFIG_MLX5_EN_IPSEC=y
debian.master/config/config.common.ubuntu:CONFIG_XFRM_OFFLOAD=y
debian.master/config/annotations:CONFIG_MLX5_EN_IPSEC                           
 policy<{'amd64': 'y', 'arm64': 'y', 'armhf': 'y', 'i386': 'y', 'ppc64el': 'y', 
's390x': 'y'}>
debian.master/config/annotations:CONFIG_INET_ESP_OFFLOAD                        
 policy<{'amd64': 'm', 'arm64': 'm', 'armhf': 'm', 'i386': 'm', 'ppc64el': 'm', 
's390x': 'm'}>
debian.master/config/annotations:CONFIG_INET6_ESP_OFFLOAD                       
 policy<{'amd64': 'm', 'arm64': 'm', 'armhf': 'm', 'i386': 'm', 'ppc64el': 'm', 
's390x': 'm'}>


** Changed in: linux (Ubuntu Bionic)
       Status: Fix Committed => Fix Released

** Changed in: ubuntu-power-systems
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1742939

Title:
  MLX: Set network offload for ppc64el

Status in The Ubuntu-power-systems project:
  Fix Released
Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Bionic:
  Fix Released

Bug description:
  == Comment: #0 - Breno Leitao <bren...@br.ibm.com> - 2018-01-12 07:01:25 ==
  Hi Canonical,

  
  We've been looking at an adapter from Mellanox and we need to do some kernel 
config changes. 

  This adapter is essentially an ethernet adapter with accelerators ,
  capable of doing some interesting network offloads, such as offload of
  IPsec. There was some kernel support that went upstream fairly
  recently that is needed to support it.

   The kernel config options are:
   
  CONFIG_XFRM_OFFLOAD
  CONFIG_INET_ESP_OFFLOAD
  CONFIG_INET6_ESP_OFFLOAD
  CONFIG_MLX5_ACCEL
  CONFIG_MLX5_EN_IPSEC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-power-systems/+bug/1742939/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to