Re-tested with Trusty 4.4, the fix works as expected.
Thanks.

** Changed in: ubuntu-kernel-tests
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-aws in Ubuntu.
https://bugs.launchpad.net/bugs/1786222

Title:
  config_stack_protector_strong is needed for AWS Trusty 4.4

Status in QA Regression Testing:
  Fix Released
Status in ubuntu-kernel-tests:
  Fix Released
Status in linux-aws package in Ubuntu:
  Invalid

Bug description:
  Failure reported in the ubuntu_qrt_kernel_security:

    FAIL: test_185_config_stack_protector_strong 
(__main__.KernelSecurityConfigTest)
    CONFIG_CC_STACKPROTECTOR_STRONG set
    ----------------------------------------------------------------------
    Traceback (most recent call last):
    File "./test-kernel-security.py", line 2350, in 
test_185_config_stack_protector_strong
    self.assertKernelConfig(config_option, expected)
    File "./test-kernel-security.py", line 207, in assertKernelConfig
    self.assertKernelConfigSet(name)
    File "./test-kernel-security.py", line 194, in assertKernelConfigSet
    '%s option was expected to be set in the kernel config' % name)
    AssertionError: CC_STACKPROTECTOR_STRONG option was expected to be set in 
the kernel config

To manage notifications about this bug go to:
https://bugs.launchpad.net/qa-regression-testing/+bug/1786222/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to