This bug is missing log files that will aid in diagnosing the problem.
While running an Ubuntu kernel (not a mainline or third-party kernel)
please enter the following command in a terminal window:

apport-collect 1806914

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

** Tags added: bionic

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1806914

Title:
  [18.04] update-initramfs fails to generate correct initrd

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  Hi

  I get many trouble in trying to generate a correct initrd.img for the
  following configuration

  clear lvm on /dev/sd4 partition (msdos)
  several logical volumes, some clear and some luks-encrypted
  / et /home on encrypted logical volumes, each with its own 512 byte binary 
key-file on removable device (USB stick)
  /boot et /usr on clear logical volumes

  I am still running 14.04 due to trouble with 16.04, maybe because I
  missed the introduction of the "initramfs" crypttab option. I dropped
  any investigation hoping for the trouble being solved with 18.04. This
  is not the case.

  I run into trouble as soon as I tried to update initrd.img with
  update-initramfs.

  victor-odos goes to /, victor-oikia goes to /home
  I rewrote passdev and stored it in /lib/cryptsetup/bash/passdev

  1/ with crypttab referencing my binary key-files

  victor-odos /dev/mapper/victor-odos_l 
/dev/disk/by-uuid/4146dfad-26f0-4aec-99c3-8ab00c3e4297:/.ckf/victor-odos:1 
luks,keyscript=/lib/cryptsetup/bash/passdev,initramfs
  victor-oikia /dev/mapper/victor-oikia_l 
/dev/disk/by-uuid/4146dfad-26f0-4aec-99c3-8ab00c3e4297:/.ckf/victor-oikia:1 
luks,keyscript=/lib/cryptsetup/bash/passdev,initramfs

  I join two files : /dev/stdout sent to .log and /dev/stderr to .err

  2/ with no key-files

  victor-odos /dev/mapper/victor-odos_l none luks,initramfs
  victor-oikia /dev/mapper/victor-oikia_l none luks,initramfs

  
  I don't know how to bypass this issue 

  
  When this has been solved, I intend to detach luks headers. How to code 
crypttab as I don't know the operational file hierarchy inside initrd ?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1806914/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to