It's not a bug: I brought the T480s to the Lenovo support. The keyboard
was malfunctioned, so they changed it.

Now everything works just fine.

** Changed in: linux (Ubuntu)
       Status: Confirmed => Invalid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ETPS/2 Elantech TrackPoint is locked vertically / can not move pointer
  right and left

Status in linux package in Ubuntu:

Bug description:
  I am using a Lenovo Thinkpad T480s with Ubuntu Mate 18.04. On the
  fresh setup the trackpoint worked flawlessly. After some kernel
  updates (current one is 4.15.0-44) the trackpoint got
  "stucked"/"locked" vertically. That means I can only move the pointer
  up and down and not right and left. Sometimes I can move the pointer
  to the right but then it jumps around uncontrollably and gets locked
  at the right end of the desktop.

  I tried a lot of different things: Compiled newest libinput, tried
  hwe-kernel 4.18 and mainline-kernel 4.20. None of these made it work.
  On random occassions the trackpoint worked fine but got stucked once
  again in the same session. I think it got stucked when I
  simultaneously moved the trackpoint and touched the touchpad with my

  Touchpad is working fine though!

  $ xinput
  ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer                      id=4    [slave  pointer 
  ⎜   ↳ ETPS/2 Elantech Touchpad                        id=11   [slave  pointer 
  ⎜   ↳ ETPS/2 Elantech TrackPoint                      id=12   [slave  pointer 
  ⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
      ↳ Virtual core XTEST keyboard                     id=5    [slave  
keyboard (3)]
      ↳ Power Button                                    id=6    [slave  
keyboard (3)]
      ↳ Video Bus                                       id=7    [slave  
keyboard (3)]
      ↳ Sleep Button                                    id=8    [slave  
keyboard (3)]
      ↳ Integrated Camera: Integrated C                 id=9    [slave  
keyboard (3)]
      ↳ AT Translated Set 2 keyboard                    id=10   [slave  
keyboard (3)]
      ↳ ThinkPad Extra Buttons                          id=13   [slave  
keyboard (3)]

  $ dmesg | grep -i elan
  [    2.930410] psmouse serio1: elantech: assuming hardware version 4 (with 
firmware version 0x7f3001)
  [    2.940877] psmouse serio1: elantech: Synaptics capabilities query result 
0x90, 0x18, 0x0f.
  [    2.951284] psmouse serio1: elantech: Elan sample query result 00, 20, c9
  [    2.994917] input: ETPS/2 Elantech TrackPoint as 
  [    3.008529] input: ETPS/2 Elantech Touchpad as 

  Is this a driver issue with elantech driver because the T480s is new 
hardware? I stumpled upon different patches from Benjamin Tissoires who 
suggests something like that:

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-44-generic 4.15.0-44.47
  ProcVersionSignature: Ubuntu 4.15.0-44.47-generic 4.15.18
  Uname: Linux 4.15.0-44-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
   /dev/snd/controlC0:     1974 F.... pulseaudio
  CurrentDesktop: MATE
  Date: Wed Jan 30 21:59:58 2019
  HibernationDevice: RESUME=UUID=0f5f9333-5826-4e4b-ba22-a0a7fce65754
  InstallationDate: Installed on 2018-07-27 (187 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 5986:2113 Acer, Inc
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20L8S02D00
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-44-generic 
root=UUID=a69059e4-d10d-471b-a8a9-88692ccbabdd ro quiet splash vt.handoff=1
   linux-restricted-modules-4.15.0-44-generic N/A
   linux-backports-modules-4.15.0-44-generic  N/A
   linux-firmware                             1.173.3
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install) 04/09/2018
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N22ET35W (1.12 )
  dmi.board.asset.tag: Not Available 20L8S02D00
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Defined
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
dmi:bvnLENOVO:bvrN22ET35W(1.12):bd04/09/2018:svnLENOVO:pn20L8S02D00:pvrThinkPadT480s:rvnLENOVO:rn20L8S02D00:rvrNotDefined:cvnLENOVO:ct10:cvrNone: ThinkPad T480s 20L8S02D00
  dmi.product.version: ThinkPad T480s
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to