I remembered some additional information I should have put in the
original post:

First: Just to be sure, I wanted to reiterate that the 128 GB USB drive
was not just a "boot drive". It was an exact duplicate of the entire
Ubuntu system from my laptop, and worked the exact same way (Trash
function and all).

Second: As noted, the update from Software Updater that required a
restart broke both (1) the GRUB 2 bootloader on the (booted) USB drive,
AND (2) the GRUB 2 bootloader on the (unmounted) laptop's hard drive.

When I said they were broken to the point where neither was bootable,
taking me to the dreaded "grub_rescue" command line when trying to boot
either one, I should have added the following regarding the errors
given:

1) When trying to boot from the USB drive (during the restart), the
error was similar to "trying to read outside hd0" (hd0 = the hard drive,
I believe), before I was put at grub_rescue command line. (To note, I
have seen that same error at other *unrelated* times, but at those
times, it acted more like a warning pause before simply continuing to
the login screen.)

2) Then removing the USB drive and attempting to simply boot up from the
hard drive instead, I got an error similar to "cannot find (or locate)
device such-and-such" before being put at grub_rescue. I believe the
"such-and-such" was the UUID of the USB drive that was being run from
when the update that required a restart came up. So even though trying
to boot up from the hard drive at that point, it still knew something
about the previously-booted USB drive that was active during the
restart-requiring-update; and it didn't like that it couldn't find that
USB drive, so grub_rescue ensued.

That's it. Thank you again!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1815225

Title:
  Ubuntu System on USB Drive Breaks with Updates Requiring Restarts

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  First, please forgive me if I do not report this issue correctly. I'm
  new here and don't generally live in the Launchpad world. (I've tried
  this at askUbuntu.com, and it was suggested I come here.)

  In brief: I have a 2006 Dell Inspiron (32 bit) with a (slow) 40 GB
  hard drive running Ubuntu 14.04 LTS. Having the system exactly the way
  I want it, I used the application "Systemback" to install the system
  on a (fast) 128 GB USB drive, which, being bootable, worked exactly
  the same as if I booted from the hard drive. So I started using the
  faster 128 USB drive exclusively.

  Now typically, Software Updater, if not requiring a restart, updated the 
running USB drive just fine. But one day, after Software Updater did an update 
that required a restart, this happened:
  the GRUB 2 bootloader the USB drive that was booted from, AND ALSO the GRUB 2 
bootloader on the laptop's hard drive got broken, to the point where neither 
was bootable, taking me to the dreaded "grub rescue" command line when trying 
to boot either one. (Thankfully, I had a second USB drive with my Ubuntu system 
on it, and was able to install it from there to both the laptop's hard drive 
and the other now-ruined USB drive to bring them back to a pre-broken, normal 
existence.)

  With that background, I ask: Can Ubuntu's updates that require
  restarts merely work with the drive that was booted from, and not any
  affect any others (including an unmounted hard drive that was not
  booted from) ?

  If so, then anyone could get a Linux the way they want that they can
  take anywhere, bootable from any computer, AND update-able from any
  computer, bypassing all need for hard drives of any sort. No longer
  would people need to even buy laptops with hard drives or even
  operating systems. They could simply buy a smaller, cheaper, hard-
  drive-less and OS-less device that runs merely by plugging an Ubuntu
  Linux USB drive into it as "the system".

  Thank you very much for your time!

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-165-generic 3.13.0-165.215
  ProcVersionSignature: Ubuntu 3.13.0-165.215-generic 3.13.11-ckt39
  Uname: Linux 3.13.0-165-generic i686
  ApportVersion: 2.14.1-0ubuntu3.29
  Architecture: i386
  AudioDevicesInUse:
   USER        PID ACCESS COMMAND
   /dev/snd/controlC0:  noname     2014 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Fri Feb  8 12:12:35 2019
  HibernationDevice: RESUME=UUID=230fdc83-e7b8-40a5-8731-075b72792c69
  InstallationDate: Installed on 2018-12-31 (39 days ago)
  InstallationMedia:
   
  IwConfig:
   lo        no wireless extensions.
   
   eth0      no wireless extensions.
  MachineType: Dell Inc. ME051
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-165-generic 
root=UUID=7cfb23c6-b380-495e-9e1c-813436961fef ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-3.13.0-165-generic N/A
   linux-backports-modules-3.13.0-165-generic  N/A
   linux-firmware                              1.127.24
  RfKill:
   
  SourcePackage: linux
  UpgradeStatus: Upgraded to trusty on 2018-12-31 (39 days ago)
  WifiSyslog:
   
  dmi.bios.date: 12/22/2005
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A04
  dmi.board.name: 0TD535
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA04:bd12/22/2005:svnDellInc.:pnME051:pvr:rvnDellInc.:rn0TD535:rvr:cvnDellInc.:ct8:cvr:
  dmi.product.name: ME051
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1815225/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to