This bug was erroneously marked for verification in bionic; verification
is not required and verification-needed-bionic is being removed.

** Tags removed: verification-needed-bionic

** Tags added: verification-done-bionic

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1758507

Title:
  sky2 gigabit ethernet driver sometimes stops working after lid-open
  resume from sleep (88E8055)

Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Xenial:
  Fix Released
Status in linux source package in Artful:
  Fix Released
Status in linux source package in Bionic:
  Fix Released

Bug description:
  ===SRU Justification===
  [Impact]
  sky2 ethernet stops working after system resume from suspend.

  [Fix]
  Increase the PCI D3 delay can workaround the issue.

  [Test]
  User responded that the D3 delay increase can solve the issue.

  [Regression Potential]
  Low. It only affects one device. The fix only increase the delay timer,
  without any functional change.

  ===Original Bug Report===
  After resuming from sleep using the lid-open event, OFTEN (60% replicable, 
usually after 2nd or later resume) the NIC is not functional, and reloading the 
sky2 module does not help. Relevant parts from dmesg:

  [  582.852065] sky2 0000:04:00.0: Refused to change power state, currently in 
D3
  ...<after another suspend-resume>
  [  827.613729] sky2 0000:04:00.0: ignoring stuck error report bit
  [  827.613748] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613750] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613752] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613754] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613756] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613759] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613761] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613763] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613765] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613767] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613769] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613772] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613774] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613776] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613778] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613780] sky2 0000:04:00.0: enp4s0: phy I/O error
  [  827.613782] sky2 0000:04:00.0: enp4s0: phy I/O error

  And after reloading the module:
  [ 1421.781480] sky2: driver version 1.30
  [ 1421.781533] sky2 0000:04:00.0: enabling device (0000 -> 0003)
  [ 1421.781667] sky2 0000:04:00.0: unsupported chip type 0xff
  [ 1421.782292] sky2: probe of 0000:04:00.0 failed with error -95

  Possibly relevant:
  [ 1235.944086] ACPI: button: The lid device is not compliant to SW_LID.

  Replicability: When it happens once, further suspend-resume cycles (tried ~5) 
don't fix it. Reboot fixes the NIC, and it often survives first resume after 
that, but 1-2 suspend-resume cycles later the issue WILL occur again.
  Per-boot chance of encountering the issue - so far 2/5.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-12-generic 4.15.0-12.13
  ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
  Uname: Linux 4.15.0-12-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 
k4.15.0-12-generic.
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
  ApportVersion: 2.20.8-0ubuntu10
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 
'arecord'
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', 
'/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', 
'/dev/snd/controlC0', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  Card0.Amixer.info: Error: [Errno 2] No such file or directory: 'amixer': 
'amixer'
  Card0.Amixer.values: Error: [Errno 2] No such file or directory: 'amixer': 
'amixer'
  Date: Sat Mar 24 09:54:10 2018
  HibernationDevice: RESUME=UUID=02d18685-fc92-4ebe-a43e-34d1e52a26b1
  InstallationDate: Installed on 2018-03-21 (3 days ago)
  InstallationMedia: Ubuntu-Server 18.04 LTS "Bionic Beaver" - Alpha amd64 
(20180319)
  IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
  MachineType: FUJITSU SIEMENS ESPRIMO Mobile U9200
  ProcEnviron:
   LANGUAGE=en_US:en
   TERM=linux
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-12-generic 
root=UUID=bc171dce-b703-44f6-8244-22b6b3b1dc33 ro video=SVIDEO-1:d 
consoleblank=300
  RelatedPackageVersions:
   linux-restricted-modules-4.15.0-12-generic N/A
   linux-backports-modules-4.15.0-12-generic  N/A
   linux-firmware                             1.173
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/22/2008
  dmi.bios.vendor: Phoenix
  dmi.bios.version: 1.11 - 067 - 1566
  dmi.board.name: S11D
  dmi.board.vendor: FUJITSU SIEMENS
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: FSC
  dmi.chassis.type: 10
  dmi.chassis.vendor: FUJITSU SIEMENS
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnPhoenix:bvr1.11-067-1566:bd04/22/2008:svnFUJITSUSIEMENS:pnESPRIMOMobileU9200:pvr1.0:rvnFUJITSUSIEMENS:rnS11D:rvr1.0:cvnFUJITSUSIEMENS:ct10:cvr1.0:
  dmi.product.name: ESPRIMO Mobile U9200
  dmi.product.version: 1.0
  dmi.sys.vendor: FUJITSU SIEMENS

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1758507/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to