This bug was erroneously marked for verification in bionic; verification
is not required and verification-needed-bionic is being removed.

** Tags removed: verification-needed-bionic
** Tags added: kernel-fixup-verification-needed-bionic verification-done-bionic

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Shared folders cannot be mounted in ubuntu/cosmic64 due to missing
  vbox modules

Status in cloud-images:
  Fix Released
Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Cosmic:
  Fix Committed

Bug description:
  SRU Justification

  Impact: Vagrant environments are no longer able to use virtualbox
  feartures like shared folders. This is due to Ubuntu Cosmic kernels
  currently shipping the upstream vboxguest module and not importing
  modules from the virtualbox-guest-dkms package.

  Fix: One solution would be to use the dkms modules for Vagrant, but
  this is not ideal. At this late stage the simplest solution is to go
  back to importing the out-of-tree modules.

  Regression Potential: Minimal. Will have no impact outside of
  virtualbox environments, and the drivers being imported come from the
  virtualbox-guest-dkms package in cosmic and are thus expected to work


  In bionic, the vboxsf module was included in linux-

  $ dpkg -c linux-modules-4.15.0-36-generic_4.15.0-36.39_amd64.deb | grep 
  -rw-r--r-- root/root     63238 2018-09-24 10:08 

  In cosmic, it isn't:

  $ dpkg -c ~/Downloads/linux-
  modules-4.18.0-9-generic_4.18.0-9.10_amd64.deb | grep vboxsf.ko

  This results in shared folders no longer being mountable in Ubuntu
  Vagrant boxes (and, as the other vbox modules are also missing,
  probably has other effects that haven't yet been reported).

  [Original Report]

  Just tried to test out the new cosmic64 vagrant box and get the
  following error;

  Vagrant was unable to mount VirtualBox shared folders. This is usually
  because the filesystem "vboxsf" is not available. This filesystem is
  made available via the VirtualBox Guest Additions and kernel module.
  Please verify that these guest additions are properly installed in the
  guest. This is not a bug in Vagrant and is usually caused by a faulty
  Vagrant box. For context, the command attempted was:

  mount -t vboxsf -o uid=1000,gid=1000 vagrant /vagrant

  The error output from the command was:

  /sbin/mount.vboxsf: mounting failed with the error: No such device

  I tried with ubuntu/bionic64 and it worked fine.

  I've got;
  $ vagrant version
  Installed Version: 2.1.5
  Latest Version: 2.1.5

  You're running an up-to-date version of Vagrant!
  $ VBoxManage --version

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to