** Changed in: hwe-next
       Status: New => Fix Released

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  USB cardreader (0bda:0328) make the system can't enter s3 or hang

Status in HWE Next:
  Fix Released
Status in linux package in Ubuntu:
Status in linux source package in Bionic:
  Fix Released

Bug description:
  We have a couple o lenovo laptops, they have the realtek cardreader 
  this cardreader is the latest product from realtek, and it uses the common
  usb-to-scsi driver UAS. When the system suspend and resume, the USB host will
  print some errors like can't disable the device under this USB bus and
  reset-and-verify fails, after that the system can't suspend anymore and hang

  the mainline build v4.17-rc1 doesn't have this issue, so through bisecting,
  we found this patch can fix the problem.

  [Test Case]
  suspend and resume 30 times, and plug sd storage card into the cardreader,
  everything worked well.

  [Regression Potential]
  Low, we tested this patch on 7 different lenovo laptops. After suspending
  and resuming for 30 times, the system still worked well, and plug a usb
  storage, it still worked well.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to