I also have the same problem on Ubuntu 18.04.2.
The login screen starts normally, but right after typing my password and 
pressing enter the screen is black.

The problem started after an NVIDIA driver update with "apt upgrade". I was 
using the nvidia driver form the CUDA Repository.
I tried removing and reinstalling nvidia-390 from Ubuntu repos, 410 and 418 
from cuda repo and 418 runfile installer from NVIDIA Homepage. The bug is the 
same for all driver versions.

When I uninstall nvidia driver und use nouveau, everything is fine.
Also when using the nvidia driver i can login with SSH and `systemctl stop 
gdm.service` + `systemctl start gdm.service`, then login works fine.
Finally switching to lightdm also works now as workaround.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to nvidia-graphics-drivers-390 in Ubuntu.
https://bugs.launchpad.net/bugs/1763774

Title:
  nvidia-driver-390 GDM black screen / hang after login

Status in nvidia-graphics-drivers-390 package in Ubuntu:
  Confirmed

Bug description:
  Ubuntu 18.04 x64 / gdm
  AMD 1800x
  Aorus Gaming K7 (x370 chipset) motherboard
  NVidia GTX 1080Ti w/ DisplayPort attached 4k monitor
  USB keyboard / mouse

  I've recently upgraded from Ubuntu 17.10 x64 to 18.04 x64 via
  `do-release-upgrade -d` and uninstalled / purged / reinstalled my NVidia
  native drivers using the `ubuntu-drivers autoinstall` approach.

  I am able to boot the system and it displays the X login shell at native
  resolution with a functioning keyboard and mouse, but I cannot
  ctrl+alt+F{1,2,3,4,...} to a non-graphical terminal.

  When I click "Sign in" using gnome 3, gnome classic, or Unity, I get a
  black screen and my input devices hang (keyboard caps lock key no longer
  functions.) If I unplug and replug my input devices, they remain
  hanging, with a stuck-on capslock indicator.  The mouse is also
  illuminated.

  I am able to SSH into the machine, and it is still usable. systemctl
  status gdm.service indicates that gdm is "running" and does not show an
  error, but it shows that the login session opened and closed very quickly.

  I rebooted and SSH'd into the machine before the hang, halted GDM via
  `systemctl stop gdm.service` and was able to ctrl+alt+F1 into another
  shell on the attached keyboard. I then executed `systemctl restart
  gdm.service` and got the expected X login shell. I was then able to log
  into the desktop environment normally.

  My Xorg.0.log is here for the successful login:
  https://paste.ubuntu.com/p/SNqJPxV938/

  I'll reproduce the behavior and attach an xorg log for the unexpected
  behavior.

  Bodie

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: nvidia-driver-390 390.48-0ubuntu1
  ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
  Uname: Linux 4.15.0-15-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu4
  Architecture: amd64
  Date: Fri Apr 13 12:43:48 2018
  InstallationDate: Installed on 2017-10-30 (165 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  SourcePackage: nvidia-graphics-drivers-390
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1763774/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to