Thank you for your quick response!

This regression / bug was found out almost 2 YEARS ago:
https://bbs.archlinux.org/viewtopic.php?id=225215
and a patch was sent to upstream (see post #2), but apparently it was never 
pulled.

Regarding hex vs dec, the file in master they seem to be mixing both:
https://github.com/torvalds/linux/blob/master/drivers/gpu/drm/drm_edid.c

The product id number for a specific panel is found in Xorg.log:
fgrep EDID /var/log/Xorg.0.log
[   751.496] (II) modeset(0): EDID vendor "SDC", prod id 18514

Anyway, I am hoping that Ubuntu, which has the biggest base of desktop
Linux users (and in particular of people who may have bought laptops
without pre-installed Windows, like Lenovo G50-80 and G50-70), would
choose to fix this regression for Ubuntu users.

** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1819968

Title:
  Colour banding in Lenovo G50-80 laptop display (i915)

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Colour bandind is visible everywhere in the system. I believe it's not
  a hardware problem, since booting with 'nomodeset' works as expected
  and the previously installed Ubuntu 14.04 also worked.

  I tried installing kernel 4.18.0-16.17 from ppa:canonical-kernel-
  team/ppa but the problem remained.

  There were already similar bugs,
  https://bugs.launchpad.net/bugs/1749420 ,
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1794387 and
  https://bugs.launchpad.net/bugs/1788308, but the fixes provided for
  those bugs did not work for my specific monitor.

  cat /proc/version_signature
  Ubuntu 4.15.0-46.49-generic 4.15.18

  sudo lspci -vnvn
  00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller 
[8086:0a04] (rev 0b)
   Subsystem: Lenovo Haswell-ULT DRAM Controller [17aa:390b]
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort+ >SERR- <PERR- INTx-
   Latency: 0
   Capabilities: [e0] Vendor Specific Information: Len=0c <?>
   Kernel driver in use: hsw_uncore

  00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT 
Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA 
controller])
   Subsystem: Lenovo Haswell-ULT Integrated Graphics Controller [17aa:390b]
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B- DisINTx+
   Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort- >SERR- <PERR- INTx-
   Latency: 0
   Interrupt: pin A routed to IRQ 46
   Region 0: Memory at b0000000 (64-bit, non-prefetchable) [size=4M]
   Region 2: Memory at a0000000 (64-bit, prefetchable) [size=256M]
   Region 4: I/O ports at 4000 [size=64]
   [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
   Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Address: fee02004  Data: 4023
   Capabilities: [d0] Power Management version 2
    Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [a4] PCI Advanced Features
    AFCap: TP+ FLR+
    AFCtrl: FLR-
    AFStatus: TP-
   Kernel driver in use: i915
   Kernel modules: i915

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1819968/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to