This also affects me on a fresh Arch Linux install with the RX 580 8GB
GPU. I have found a temporary workaround to this issue until it is
finally solved. I used Budgie Settings to enable the execution of this
command each time it enters the environment:

xrandr --output HDMI-A-0 --mode 1920x1080 -r 60

This disables the flickering if executed as the system enters the
desktop environment. Replace your output with whatever you use (in my
case, I use HDMI-A-0). Of course, it will cap your frame-rate at 60Hz
but it's better than having the flickering lines at the bottom of the

Your use may vary, but this worked for me.

** Also affects: archlinux
   Importance: Undecided
       Status: New

** Package changed: archlinux => linux (Arch Linux)

** No longer affects: linux (Arch Linux)

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [amdgpu] Flickering graphics corruption (but none observed in kernels

Status in linux package in Ubuntu:
Status in xserver-xorg-video-amdgpu package in Ubuntu:

Bug description:
  The screen always flickers at a frequency of 75 GHz on the AMD RX 580 gpu. At 
60 and 50 GHz, if you switch to any other than 75, the flickering will 
disappear until the display turns off. After switching on, flicker returns. At 
the core of 4.18.0-10, just like on the AMD Radeon HD7970 gpu, the problem is 
not visible. More in the video

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: xorg 1:7.7+19ubuntu8
  ProcVersionSignature: Ubuntu 4.18.0-13.14-generic 4.18.17
  Uname: Linux 4.18.0-13-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13.1
  Architecture: amd64
  BootLog: Error: [Errno 13] Отказано в доступе: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Jan 29 13:13:19 2019
  DistUpgraded: Fresh install
  DistroCodename: cosmic
  DistroVariant: ubuntu
   Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 
470/480/570/570X/580/580X] [1002:67df] (rev e7) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Ellesmere [Radeon RX 
470/480/570/570X/580/580X] [1043:0519]
  InstallationDate: Installed on 2019-01-22 (6 days ago)
  InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 
  MachineType: MSI MS-7693
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-13-generic 
root=UUID=ad22bc6d-c4e8-4393-a30b-6c247159b9dd ro quiet splash vt.handoff=1
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install) 01/08/2016
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: V10.6
  dmi.board.asset.tag: To be filled by O.E.M. 970A-G43 (MS-7693)
  dmi.board.vendor: MSI
  dmi.board.version: 3.0
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: MSI
  dmi.chassis.version: 3.0
dmi:bvnAmericanMegatrendsInc.:bvrV10.6:bd01/08/2016:svnMSI:pnMS-7693:pvr3.0:rvnMSI:rn970A-G43(MS-7693):rvr3.0:cvnMSI:ct3:cvr3.0: To be filled by O.E.M. MS-7693
  dmi.product.sku: To be filled by O.E.M.
  dmi.product.version: 3.0
  dmi.sys.vendor: MSI
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.97+git1901221830.b7a7a9~oibaf~c
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.0~git1901280730.d1d2bb~oibaf~c
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.1-3ubuntu2.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-3

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to