As I said, the major change that I remember was updating from ubuntu
18.04.1 to 18.04.2. I'm attaching my apt history log to this message. I
am 100% sure that hibernation wasn't crashing and worked flawlessly on
02/06/2019 and it wasn't anymore in 03/04/2019.

The bug I'm trying to describe happens in either 4.15 or kernel 5.0, the
thing is that if it wasn't ever used more than, something around 2gb, of
ram memory, the "s2disk saving image to disk" freeze doesn't happen and
I'm able to resume normally. That's on both kernels too. What I want to
make clear is that this isn't some sort of broken swap partition with
storage limitations, because even if i close all programs after such 2gb
usage the problem still happens.

Maybe I should make a huge downgrade and check out what package causes
it? I'm not sure though how to do that via apt.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  s2disk freezes at saving image to disk (hibernation)

Status in linux package in Ubuntu:

Bug description:
  This started happening after I upgrade to ubuntu 18.04.2. In 18.04.1
  hibernation was working flawlessly on my machine. (with kernel
  4.15-46! not a kernel issue then?)

  Another thing that got updated recently was nvidia drivers which were
  known to cause hibernation issues, but those were on restoring the
  snapshot.  --> I get stuck on this screen after
  running hibernate or pm-hibernate. (sys-req REISUB combination works
  there and is the only good way to restart I found)


  Laptop Dell Inspiron 7567 A30P
  Intel Core i7-7700HQ
  1x 16 GB DDR4 
  1 TB HDD + 256 GB SSD 
  Nvidia GeForce GTX 1050 
  Ti FHD display 
  Intel Dual Band Wireless AC 3165 
  1x1 Motherboard: 
  Intel HM175 Graphics adapter: 
  NVIDIA GeForce GTX 1050 Ti (Laptop) - 4096 MB, 
  Core: 1620 MHz, 
  Memory: 1752 MHz, 
  GDDR5, (ForceWare 373.20), 
  Nvidia Optimus

  nvidia driver: 415.27


  # uname -a
  Linux matheus-Inspiron-15-7000-Gaming 4.15.0-46-generic #49-Ubuntu SMP Wed 
Feb 6 09:33:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

  # free -m
                total        used        free      shared  buff/cache   
  Mem:          15906        2925        8742         161        4238       
  Swap:         16333           0       16333

  # cat /etc/fstab | grep swap
  # swap was on /dev/sda8 during installation
  UUID=70d967e6-ad52-4c21-baf0-01a813ccc6ac none            swap    sw          
    0       0

  root@matheus-Inspiron-15-7000-Gaming:/home/matheus# cat /var/log/syslog | 
grep hibernate                                     
  root@matheus-Inspiron-15-7000-Gaming:/home/matheus# cat /var/log/syslog | 
grep hiber                                         
  root@matheus-Inspiron-15-7000-Gaming:/home/matheus# cat /var/log/syslog | 
grep s2disk                                        
  root@matheus-Inspiron-15-7000-Gaming:/home/matheus# cat /var/log/syslog | 
grep hibernation

  I could find nothing scrolling up on syslog about the hibernation process or 
with grep.... 

  An interesting Note is that if I run hibernate just after I boot, it works 
and resumes perfectly! But after some system usage it randomly has that problem 
if I try. The percentage it freezes at is also random, sometimes 0, 1 even 30 
  ProblemType: Bug
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
   /dev/snd/pcmC0D0c:   matheus   25949 F...m pulseaudio
   /dev/snd/pcmC0D0p:   matheus   25949 F...m pulseaudio
   /dev/snd/controlC0:  matheus   25949 F.... pulseaudio
   /dev/snd/seq:        matheus    4986 f.... qsynth
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 18.04
  HibernationDevice: RESUME=UUID=bfc6f294-b737-4999-a444-01e1f410de06
  InstallationDate: Installed on 2018-05-10 (308 days ago)
  InstallationMedia: Kubuntu 18.04 LTS "Bionic Beaver" - Release amd64 
  MachineType: Dell Inc. Inspiron 15 7000 Gaming
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-46-generic 
root=UUID=659db14c-2a6c-4f9c-93bf-d31c4a84abb6 ro nouveau.blacklist=1 debug 
no_console_suspend systemd.log_level=info nvidia-drm.modeset=0
  ProcVersionSignature: Ubuntu 4.15.0-46.49-generic 4.15.18
   linux-restricted-modules-4.15.0-46-generic N/A
   linux-backports-modules-4.15.0-46-generic  N/A
   linux-firmware                             1.173.3
  Tags:  bionic
  Uname: Linux 4.15.0-46-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm audio cdrom dip kvm lpadmin netdev plugdev sambashare sudo 
  _MarkForUpload: True 08/15/2018
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.8.1 0P84C9
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A01
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
dmi:bvnDellInc.:bvr1.8.1:bd08/15/2018:svnDellInc.:pnInspiron157000Gaming:pvr:rvnDellInc.:rn0P84C9:rvrA01:cvnDellInc.:ct10:cvr: Inspiron Inspiron 15 7000 Gaming
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to