@Jarek: Thank you for sharing the workaround, it also works for me 100%
of the time!

I tried the 5.0.1 Kernel with the patches - in the beginning I was
hopeful because the touchpad and trackpoint survived a few sleep/wakeup
cycles, but starting from day 2 the issues returned (sometimes the
touchpad didn't even work after rebooting). Now I'm back on the 4.15.0
where the Trackpoint survives maybe 2/3 of the sleeps and otherwise
there's still the workaround above.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Touchpad and/or trackpoint stop working after S3 suspend on Lenovo X1
  Carbon 6th

Status in linux package in Ubuntu:

Bug description:
  Ubuntu 18.04.1

  Terminology in case we use different terms:
  touchpad - just the rectangular touch-sensitive surface below the keyboard 
(xinput lists it as Synaptics TM3288-011)
  trackpoint - the red thingy built into the keyboard + 3 physical buttons 
below the keyboard (trackpoint and buttons are integrated together; listed in 
xinput as TPPS/2 Elan TrackPoint)

  On September 7th, 2018, Lenovo has issued a BIOS update (v1.30), which
  enables proper S3 deep sleep state - users no longer have to patch
  DSDT tables to get it. It can be enabled in the BIOS settings. In X1
  carbon 6th generation models that have NFC, when laptop wakes from
  suspend by opening the lid, in most cases both touchpad and trackpoint
  stop working completely. They are also no longer listed when running
  xinput command. Sometimes just one of them stops working, usually the
  trackpoint. In some rare cases it is possible to bring them back by
  using these commands:

      echo -n none > /sys/devices/platform/i8042/serio1/drvctl
      echo -n reconnect > /sys/devices/platform/i8042/serio1/drvctl
      rmmod psmouse
      modprobe psmouse

  These worked properly when waking up from S2Idle sleep state (had
  these in a script that runs after waking the machine from suspend),
  but with S3 deep sleep these rarely work and the only way to bring
  back touchpad and/or trackpoint is turning off the machine and turning
  it on (restart does not help).

  I could not find any pattern that would show when the input devices
  stop working or start working again using the commands mentioned
  above. It's completely random from my perspective.

  This is happening on the standard issue 4.15.0-33-generic kernel that
  shipped with my Ubuntu 18.04 (with updates), as well as with newer
  mainline kernels, such as the newest point versions of 4.17, 4.18 and
  4.19 RC2.

  This happens regardless of whether "blacklist i2c_i801" is commented
  out in /etc/modprobe.d/blacklist.conf or not. It happens regardless of
  whether "psmouse.synaptics_intertouch=1" is passed as grub parameter.
  Presence of TLP does not make it better, nor worse.

  It appears that non-NFC models are not affected. I know at least one
  Arch Linux user who has the exact same model, but without this issue.
  I'm using synaptics driver (no libinput installed), he uses libinput
  and doesn't have synaptics, if that information is of any use.
  Libinput does not seem to help.

  This forum thread also has more details from users who updated their
  BIOS to get S3 suspend: https://forums.lenovo.com/t5/Linux-

  Another related thread:

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-33-generic 4.15.0-33.36
  ProcVersionSignature: Ubuntu 4.15.0-33.36-generic 4.15.18
  Uname: Linux 4.15.0-33-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.3
  Architecture: amd64
   /dev/snd/pcmC0D0p:   maciej     2651 F...m pulseaudio
   /dev/snd/controlC0:  maciej     2651 F.... pulseaudio
  CurrentDesktop: i3
  Date: Sat Sep  8 13:45:43 2018
  HibernationDevice: RESUME=UUID=3116dcb0-d91e-4b2a-8166-43b7a9a9d36e
  InstallationDate: Installed on 2018-07-21 (49 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 13d3:56b2 IMC Networks 
   Bus 001 Device 002: ID 04b4:0060 Cypress Semiconductor Corp. Wireless 
optical mouse
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20KH006KPB
   0 EFI VGA
   1 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-33-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash psmouse.synaptics_intertouch=1 
   linux-restricted-modules-4.15.0-33-generic N/A
   linux-backports-modules-4.15.0-33-generic  N/A
   linux-firmware                             1.173.1
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/31/2018
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N23ET55W (1.30 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20KH006KPB
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.product.family: ThinkPad X1 Carbon 6th
  dmi.product.name: 20KH006KPB
  dmi.product.version: ThinkPad X1 Carbon 6th
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to