Funny enough the boot dmesg contains some indication about the problem,
while the serial output does now (or so it seems):

[    0.627017] GPT:Primary header thinks Alt. header is not at the end of the 
disk.
[    0.628500] GPT:4194303 != 20971519
[    0.629167] GPT:Alternate GPT header not at the end of the disk.
[    0.630291] GPT:4194303 != 20971519
[    0.630951] GPT: Use GNU Parted to correct GPT errors.
[    0.632002]  vda: vda1

I have to get the image to check locally. Would be interesting to look
at the reported values and whether breaking into pre-mount allows to
reread the partition table (check whether its a race).

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1258631

Title:
  instances fails to register GPT partition entries on virtio devices

Status in “linux” package in Ubuntu:
  Confirmed
Status in “linux” source package in Raring:
  Confirmed
Status in “linux” source package in Saucy:
  Confirmed
Status in “linux” source package in Trusty:
  Confirmed

Bug description:
  When booting via KVM and using the VirtIO interface, GPT partition
  entries are not shown properly.

  ubuntu@gpt-test-4:~$ sudo parted /dev/vda -s -- print
  Model: Virtio Block Device (virtblk)
  Disk /dev/vda: 10.7GB
  Sector size (logical/physical): 512B/512B
  Partition Table: gpt

  Number  Start   End        Size         File system     Name                  
        Flags
  127     1049kB  2097kB  1049kB                           BIOS boot partition  
bios_grub
  128     2097kB  89.1MB  87.0MB  fat32               EFI System                
  boot
      1      89.1MB  10.7GB  10.6GB   ext4                 Linux filesystem

  Booting with "-hda <disk>.img"
  [    2.612975] sr 1:0:0:0: Attached scsi generic sg1 type 5
  [    2.617252] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, 
doesn't support DPO or FUA
  [    2.644685]  sda: sda1 sda127 sda128
  [    2.664314] sd 0:0:0:0: [sda] Attached SCSI disk

  Booting with "-drive if=virtio,file=<disk>.img" or "-drive 
if=scsi,file=<disk>.img":
  [    2.411933] brd: module loaded
  [    2.422616] loop: module loaded
  [    2.442178]  vda: vda1
  [    2.455559] scsi0 : ata_piix
  [    2.456868] scsi1 : ata_piix

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: udev 204-5ubuntu6
  ProcVersionSignature: Ubuntu 3.12.0-5.13-generic 3.12.2
  Uname: Linux 3.12.0-5-generic x86_64
  ApportVersion: 2.12.7-0ubuntu1
  Architecture: amd64
  Date: Fri Dec  6 18:49:57 2013
  Ec2AMI: ami-00000632
  Ec2AMIManifest: FIXME
  Ec2AvailabilityZone: nova
  Ec2InstanceType: m1.small
  Ec2Kernel: aki-00000548
  Ec2Ramdisk: ari-00000548
  Lsusb:
   Bus 001 Device 002: ID 0627:0001 Adomax Technology Co., Ltd 
   Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: OpenStack Foundation OpenStack Nova
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.12.0-5-generic 
root=LABEL=cloudimg-rootfs console=ttyS0
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/01/2007
  dmi.bios.vendor: Bochs
  dmi.bios.version: Bochs
  dmi.chassis.type: 1
  dmi.chassis.vendor: Bochs
  dmi.modalias: 
dmi:bvnBochs:bvrBochs:bd01/01/2007:svnOpenStackFoundation:pnOpenStackNova:pvr2013.1.3:cvnBochs:ct1:cvr:
  dmi.product.name: OpenStack Nova
  dmi.product.version: 2013.1.3
  dmi.sys.vendor: OpenStack Foundation

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1258631/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to