Launchpad has imported 1 comments from the remote bug at

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at

On 2019-04-25T10:24:02+00:00 Paulo Matos wrote:

Created attachment 144092
dmesg from boot

This was previously reported here:

Brand new XPS 13 9380 arrived a couple of days ago from Dell with Ubuntu
18.04 preinstalled.

Flickering started immediatelly post boot and it was constant.
I updated BIOS from 1.1.1 to 1.2.1, tried i915.fastboot and i915.enable_rc6 
combinations to no avail. 

Updated to Ubuntu 19.04 and kernel-5 to no avail. However flickering
changed from constant to only if there's a screen refresh.

Videos pre kernel 5:

Videos post kernel 5:

I attach dmesg from boot.

Reply at:

** Changed in: linux
       Status: Unknown => Confirmed

** Changed in: linux
   Importance: Unknown => Medium

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Dell XPS 13 9380 flickering  (Whiskey Lake)

Status in Linux:
Status in linux package in Ubuntu:

Bug description:
  A brand new Dell XPS 13 9380 preinstalled with Ubuntu 18.04 flickers
  to the point of being totally unusable.

  I have upgraded since to 18.10 and 19.04 with no changes. I have tried
  several combinations of the i915 parameters fastboot, enable_rc6 and
  enable_fbc to no avail.

  Examples of flickering are here:
  ProblemType: Bug
  ApportVersion: 2.20.10-0ubuntu27
  Architecture: amd64
   /dev/snd/controlC0:  gdm        1430 F.... pulseaudio
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see
  DistroRelease: Ubuntu 19.04
  InstallationDate: Installed on 2019-04-13 (10 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
  MachineType: Dell Inc. XPS 13 9380
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-1035-oem 
root=UUID=252898e9-6e96-4705-a709-2db930b7c4c7 ro quiet splash i915.fastboot=1 
i915.enable_rc6=0 vt.handoff=1
  ProcVersionSignature: Ubuntu 4.15.0-1035.40-oem 4.15.18
   Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not 
accessible: Permission denied
   No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-4.15.0-1035-oem N/A
   linux-backports-modules-4.15.0-1035-oem  N/A
   linux-firmware                           1.178
  Tags:  disco
  Uname: Linux 4.15.0-1035-oem x86_64
  UpgradeStatus: Upgraded to disco on 2019-04-24 (0 days ago)
  _MarkForUpload: True 02/14/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.2.1 0KTW76
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
dmi:bvnDellInc.:bvr1.2.1:bd02/14/2019:svnDellInc.:pnXPS139380:pvr:rvnDellInc.:rn0KTW76:rvrA00:cvnDellInc.:ct10:cvr: XPS XPS 13 9380
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to