I not sure upstream will let us change the value of mask.

Will you get the same result of you set sata_spd_limit?

link->sata_spd_limit = 0x7

I believe that corresponds to 6Gbps but I don't see a #define
we can use.

Also, is the comment accurate? Before you started debugging
did you see a hard reset fail? Thanks.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Linux 4.15 and onwards fails to initialize some hard drives

Status in linux package in Ubuntu:
Status in linux source package in Bionic:
Status in linux source package in Cosmic:

Bug description:
  I have two hard drives, the main hard drive is a TOSHIBA DT01ACA200
  the second backup hard drive is a Western Digital WD5003AZEX. I
  installed lubuntu 18.04.1 on the Toshiba HDD and it boots just fine,
  the issue is with the second hard drive, when installing the WD HDD
  wouldn't even come as an option to install, and after boot the WD HDD
  still wouldn't come up, this is the dmesg with the stock kernel (4.15)

  ata6 is the WD HDD that refuses to work. The messages:
  [  302.107650] ata6: SError: { CommWake 10B8B Dispar DevExch }
  [  302.107658] ata6: hard resetting link
  [  307.860291] ata6: link is slow to respond, please be patient (ready=0)
  [  312.120898] ata6: COMRESET failed (errno=-16)
  [  363.445120] INFO: task kworker/u8:5:201 blocked for more than 120 seconds.
  [  363.445131]       Not tainted 4.15.0-29-generic #31-Ubuntu
  [  363.445135] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables 
this message.
  [  363.445140] kworker/u8:5    D    0   201      2 0x80000000
  [  363.445155] Workqueue: events_unbound async_run_entry_fn
  [  363.445157] Call Trace:
  [  363.445171]  __schedule+0x291/0x8a0
  [  363.445177]  schedule+0x2c/0x80
  [  363.445182]  ata_port_wait_eh+0x7c/0xf0
  [  363.445186]  ? wait_woken+0x80/0x80
  [  363.445189]  ata_port_probe+0x28/0x40
  [  363.445192]  async_port_probe+0x2e/0x52
  [  363.445196]  async_run_entry_fn+0x3c/0x150
  [  363.445199]  process_one_work+0x1de/0x410
  [  363.445203]  worker_thread+0x32/0x410
  [  363.445207]  kthread+0x121/0x140
  [  363.445210]  ? process_one_work+0x410/0x410
  [  363.445214]  ? kthread_create_worker_on_cpu+0x70/0x70
  [  363.445218]  ret_from_fork+0x22/0x40

  Repeat constantly. Also when I try to turn off the computer, the
  computer seem to freeze, the lights of the keyboard and mouse turn off
  and the computer just stay on.

  I tried Tiny Core 9.0 which has linux 4.14.10, and i didn't had this
  issue, i also installed linux 4.14 on this lubuntu 18.04 using Ukuu
  Kernel Update Utility. And with this kernel version, or any previous
  version the WD HDD does work again. Here's a dmesg of lubuntu 18.04
  with linux 4.14 and the WD HDD finally coming up at the end:

  Also tried with with linux 4.17 but the WD HDD would also refuse to
  work on this version. Here's another dmesg with this version:

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-29-generic 4.15.0-29.31
  ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
  Uname: Linux 4.15.0-29-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 
  ApportVersion: 2.20.9-0ubuntu7.2
  Architecture: amd64
   /dev/snd/controlC0:  testtest    756 F.... pulseaudio
   /dev/snd/controlC1:  testtest    756 F.... pulseaudio
   Card hw:0 'NVidia_1'/'HDA NVidia at 0xfe020000 irq 22'
     Mixer name : 'Realtek ALC1200'
     Components : 'HDA:10ec0888,10ec0000,00100101 
     Controls      : 56
     Simple ctrls  : 21
   Card hw:1 'NVidia'/'HDA NVidia at 0xfcffc000 irq 16'
     Mixer name : 'Nvidia GPU 42 HDMI/DP'
     Components : 'HDA:10de0042,38422651,00100100'
     Controls      : 21
     Simple ctrls  : 3
  CurrentDesktop: LXDE
  Date: Thu Jul 26 17:10:58 2018
  HibernationDevice: RESUME=UUID=17e70869-516d-4b63-b900-e92e3c4b73b6
  InstallationDate: Installed on 2018-07-26 (0 days ago)
  InstallationMedia: Lubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
  MachineType: 113 1
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic 
root=UUID=71cf0a32-7827-49be-a2c0-cd50a72c26a1 ro quiet splash vt.handoff=1
   linux-restricted-modules-4.15.0-29-generic N/A
   linux-backports-modules-4.15.0-29-generic  N/A
   linux-firmware                             1.173.1
   0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/30/2008
  dmi.bios.vendor: Phoenix Technologies, LTD
  dmi.bios.version: 6.00 PG
  dmi.board.name: 113-M2-E113
  dmi.board.vendor: EVGA
  dmi.board.version: 1
  dmi.chassis.asset.tag: Unknow
  dmi.chassis.type: 3
  dmi.chassis.vendor: EVGA
  dmi.chassis.version: 113-M2-E113
  dmi.product.name: 1
  dmi.product.version: 1
  dmi.sys.vendor: 113

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to