This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag 'verification-needed-
disco' to 'verification-done-disco'. If the problem still exists, change
the tag 'verification-needed-disco' to 'verification-failed-disco'.

If verification is not done by 5 working days from today, this fix will
be dropped from the source code, and this bug will be closed.

See for documentation how
to enable and use -proposed. Thank you!

** Tags added: verification-needed-disco

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ideapad_laptop disables WiFi/BT radios on Lenovo Y540

Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Bionic:
  Fix Committed
Status in linux source package in Disco:
  Fix Committed
Status in linux source package in Eoan:
  Fix Released

Bug description:
  === SRU Justification ===
  WiFi on Ideapads are rfkill HW blocked by default.

  Remove no_hw_rfkill_list as most Ideapads don't have hardware rfkill

  User reported the fix works.

  [Regression Potential]
  Low. If there's any actual device that has HW rfkill button, we can
  simply add it to whitelist.

  === Original Bug Report ===
  I have a brand new LeNovo legion Y540 and the ideapad_laptop module results 
in a rfkill.

  If the module is removed/blacklisted, then wifi works, but some ACPI
  functionality is lost (the fans don't spin correctly and the laptop
  doesn't cool properly).

  I will try to compile ideapad_laptop adding the laptop info to

  I only tried in ubuntu 19.10 (although this is a kernel issue)

  rfkill output:
  sudo rfkill
  ID TYPE      DEVICE                 SOFT      HARD
   2 bluetooth hci0                blocked unblocked
   3 wlan      phy0              unblocked unblocked
   4 wlan      ideapad_wlan      unblocked   blocked
   5 bluetooth ideapad_bluetooth   blocked   blocked

  1) Ubuntu 5.0.0-20.21-generic 5.0.8
  (rest of info in attachment)
  ProblemType: Bug
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
   /dev/snd/controlC1:  jmamede    2484 F.... pulseaudio
   /dev/snd/controlC0:  jmamede    2484 F.... pulseaudio
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 19.04
  InstallationDate: Installed on 2019-07-18 (0 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  MachineType: LENOVO 81SX
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 EFI VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-20-generic 
root=/dev/mapper/lvmmamede-root ro quiet splash vt.handoff=1
  ProcVersionSignature: Ubuntu 5.0.0-20.21-generic 5.0.8
   linux-restricted-modules-5.0.0-20-generic N/A
   linux-backports-modules-5.0.0-20-generic  N/A
   linux-firmware                            1.178.3
  Tags:  disco
  Uname: Linux 5.0.0-20-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True 05/28/2019
  dmi.bios.vendor: LENOVO
  dmi.bios.version: BHCN28WW
  dmi.board.asset.tag: NO Asset Tag LNVNB161216
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0R32862 WIN
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Legion Y540-15IRH
dmi:bvnLENOVO:bvrBHCN28WW:bd05/28/2019:svnLENOVO:pn81SX:pvrLegionY540-15IRH:rvnLENOVO:rnLNVNB161216:rvrSDK0R32862WIN:cvnLENOVO:ct10:cvrLegionY540-15IRH: Legion Y540-15IRH 81SX
  dmi.product.sku: LENOVO_MT_81SX_BU_idea_FM_Legion Y540-15IRH
  dmi.product.version: Legion Y540-15IRH
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to