it also affects the nvidia 390 driver. startup after entering the unlock
key takes ~1 minute. Here are all lines containing some nvidia from
/var/sys/syslog:

*Aug 15 15:39:21 proxima systemd-udevd[529]: Process '/bin/systemctl start 
--no-block nvidia-persistenced.service' failed with exit code 1.
*Aug 15 15:39:21 proxima systemd-udevd[531]: Process '/bin/systemctl start 
--no-block nvidia-persistenced.service' failed with exit code 1.
*Aug 15 15:39:21 proxima kernel: [    1.473098] nvidia: loading out-of-tree 
module taints kernel.
*Aug 15 15:39:21 proxima kernel: [    1.473104] nvidia: module license 'NVIDIA' 
taints kernel.
*Aug 15 15:39:21 proxima kernel: [    1.488375] nvidia: module verification 
failed: signature and/or required key missing - tainting kernel
*Aug 15 15:39:21 proxima kernel: [    1.492771] nvidia-nvlink: Nvlink Core is 
being initialized, major device number 239
*Aug 15 15:39:21 proxima kernel: [    1.493018] nvidia 0000:01:00.0: vgaarb: 
changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
*Aug 15 15:39:21 proxima kernel: [    1.493089] NVRM: loading NVIDIA UNIX 
x86_64 Kernel Module  390.116  Sun Jan 27 07:21:36 PST 2019 (using threaded 
interrupts)
*Aug 15 15:39:21 proxima kernel: [    1.499204] nvidia-modeset: Loading NVIDIA 
Kernel Mode Setting Driver for UNIX platforms  390.116  Sun Jan 27 06:30:32 PST 
2019
*Aug 15 15:39:21 proxima kernel: [    1.500254] [drm] [nvidia-drm] [GPU ID 
0x00000100] Loading driver
*Aug 15 15:39:21 proxima kernel: [    1.500255] [drm] Initialized nvidia-drm 
0.0.0 20160202 for 0000:01:00.0 on minor 0
*Aug 15 15:39:21 proxima kernel: [    8.323475] nvidia-uvm: Loaded the UVM 
driver in 8 mode, major device number 236
*Aug 15 15:39:21 proxima kernel: [    8.771481] caller 
os_map_kernel_space.part.10+0x113/0x140 [nvidia] mapping multiple BARs
*Aug 15 15:39:21 proxima kernel: [    9.295043] audit: type=1400 
audit(1565876361.508:3): apparmor="STATUS" operation="profile_load" 
profile="unconfined" name="nvidia_modprobe" pid=917 comm="apparmor_parser"
*Aug 15 15:39:21 proxima kernel: [    9.295045] audit: type=1400 
audit(1565876361.508:4): apparmor="STATUS" operation="profile_load" 
profile="unconfined" name="nvidia_modprobe//kmod" pid=917 comm="apparmor_parser"
*Aug 15 15:39:21 proxima kernel: [    9.468531] input: HDA NVidia HDMI/DP,pcm=3 
as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input7
*Aug 15 15:39:21 proxima kernel: [    9.468570] input: HDA NVidia HDMI/DP,pcm=7 
as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input8
*Aug 15 15:39:21 proxima kernel: [    9.468601] input: HDA NVidia HDMI/DP,pcm=8 
as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input9
*Aug 15 15:39:21 proxima kernel: [    9.468631] input: HDA NVidia HDMI/DP,pcm=9 
as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input10
*Aug 15 15:40:21 proxima systemd-udevd[529]: Spawned process 
'/usr/bin/nvidia-smi' [602] is taking longer than 59s to complete
*Aug 15 15:40:21 proxima systemd-udevd[505]: nvidia: Worker [529] processing 
SEQNUM=2876 is taking a long time
*Aug 15 15:40:21 proxima kernel: [   69.065286] caller 
os_map_kernel_space.part.10+0x113/0x140 [nvidia] mapping multiple BARs

as you can see it's also because of nvidia-smi

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to nvidia-graphics-drivers-390 in Ubuntu.
https://bugs.launchpad.net/bugs/1825663

Title:
  Regression: With "nomodeset" in grub, very long boot times due to
  "/usr/bin/nvidia-smi"

Status in nvidia-graphics-drivers-390 package in Ubuntu:
  New
Status in nvidia-graphics-drivers-418 package in Ubuntu:
  Confirmed

Bug description:
  When booting with the Nvidia drivers version 418 with the following
  GRUB setting:

  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

  Boot process takes a very long time to complete.

  Output from /var/sys/syslog

  Apr 20 07:58:28 matt-tower systemd-resolved[1027]: Server returned error 
NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying 
transaction with reduced feature level UDP.
  Apr 20 07:58:28 matt-tower systemd-resolved[1027]: message repeated 2 times: 
[ Server returned error NXDOMAIN, mitigating potential DNS violation 
DVE-2018-0001, retrying transaction with reduced feature level UDP.]
  Apr 20 07:58:29 matt-tower systemd[1]: NetworkManager-dispatcher.service: 
Succeeded.
  Apr 20 07:58:30 matt-tower systemd-resolved[1027]: Server returned error 
NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying 
transaction with reduced feature level UDP.
  Apr 20 07:58:30 matt-tower systemd-resolved[1027]: message repeated 2 times: 
[ Server returned error NXDOMAIN, mitigating potential DNS violation 
DVE-2018-0001, retrying transaction with reduced feature level UDP.]
  Apr 20 07:58:43 matt-tower systemd[1]: systemd-fsckd.service: Succeeded.
  Apr 20 07:58:45 matt-tower systemd-timesyncd[1025]: Synchronized to time 
server 91.189.91.157:123 (ntp.ubuntu.com).
  Apr 20 07:58:46 matt-tower systemd[1]: systemd-hostnamed.service: Succeeded.
  Apr 20 07:59:12 matt-tower systemd-udevd[588]: Spawned process 
'/usr/bin/nvidia-smi' [657] is taking longer than 59s to complete
  Apr 20 07:59:12 matt-tower systemd-udevd[548]: nvidia: Worker [588] 
processing SEQNUM=2799 is taking a long time
  Apr 20 07:59:13 matt-tower kernel: [   76.679951] snd_hda_intel 0000:00:1b.0: 
couldn't bind with audio component
  Apr 20 07:59:13 matt-tower kernel: [   76.703584] snd_hda_codec_realtek 
hdaudioC0D2: autoconfig for ALC892: line_outs=3 (0x14/0x15/0x16/0x0/0x0) 
type:line
  Apr 20 07:59:13 matt-tower kernel: [   76.703586] snd_hda_codec_realtek 
hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
  Apr 20 07:59:13 matt-tower kernel: [   76.703587] snd_hda_codec_realtek 
hdaudioC0D2:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)

  This issue did not happen with the nvidia-driver-390, nor on ubuntu
  18.10 with the 418 drivers via the PPA.

  This is a performance regression.

  Unfortunately, if I do not set "nomodeset" in GRUB, then the plymouth
  splash screen and entire boot process is a blank screen, which makes
  it difficult to enter my LUKS encryption key. (in other words,
  removing "nomodeset" from GRUB is not an option)

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: nvidia-driver-418 418.56-0ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
  Uname: Linux 5.0.0-13-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.10-0ubuntu27
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Apr 20 08:07:55 2019
  InstallationDate: Installed on 2019-04-20 (0 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: nvidia-graphics-drivers-418
  UpgradeStatus: Upgraded to disco on 2019-04-20 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1825663/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to