for me, it's flicker-free but it doesn't show the vendor logo, only the
spinner appears during boot.

But for the first boot, it worked fine

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  i915: Display flickers during "flickerfree" boot (BIOS logo on a black

Status in linux package in Ubuntu:

Bug description:
  I am trying flickerfree boot in 19.10 [1], but find it actually
  flickers part way through:

    1. BIOS logo on a black background.
    2. Display mode resets, no image on a black background briefly.
    3. BIOS logo on a black background.

  The flicker occurs seemingly during kernel startup since my
  peripherals are lit up before the problem occurs.

  Suspecting this might be related to FB handover:

    [    2.751028] fb0: switching to inteldrmfb from EFI VGA

  I tried disabling that with a big hammer:


  so it stays in efifb, and that works -- no more flickering, providing
  I don't let i915 take over the framebuffer.


  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: linux-image-5.2.0-8-generic 5.2.0-8.9
  ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
  Uname: Linux 5.2.0-8-generic x86_64
  ApportVersion: 2.20.11-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', 
'/dev/snd/controlC0', '/dev/snd/hwC0D2', '/dev/snd/hwC0D0', 
'/dev/snd/pcmC0D9p', '/dev/snd/pcmC0D8p', '/dev/snd/pcmC0D7p', 
'/dev/snd/pcmC0D3p', '/dev/snd/pcmC0D2c', '/dev/snd/pcmC0D0c', 
'/dev/snd/pcmC0D0p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  Date: Wed Jul 17 16:34:36 2019
  InstallationDate: Installed on 2019-05-02 (76 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan EANIMAL" - Alpha amd64 (20190501)
  MachineType: LENOVO 10M7CTO1WW
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.2.0-8-generic 
root=UUID=9bfb5f01-bdd4-4854-bfce-1c28e2f2f3bc ro quiet splash i915.fastboot=1 
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-5.2.0-8-generic N/A
   linux-backports-modules-5.2.0-8-generic  N/A
   linux-firmware                           1.180
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install) 02/06/2018
  dmi.bios.vendor: LENOVO
  dmi.bios.version: M16KT47A 3102
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40709 WIN 3259627060530
  dmi.chassis.type: 3
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
dmi:bvnLENOVO:bvrM16KT47A:bd02/06/2018:svnLENOVO:pn10M7CTO1WW:pvrThinkCentreM710s:rvnLENOVO:rn3102:rvrSDK0J40709WIN3259627060530:cvnLENOVO:ct3:cvrNone: ThinkCentre M710s 10M7CTO1WW
  dmi.product.sku: LENOVO_MT_10M7_BU_Think_FM_ThinkCentre M710s
  dmi.product.version: ThinkCentre M710s
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to