Same issue here, Dell 9570. It seems to happen more often when I have
Bluetooth devices associated.

[ 5954.587078] ath10k_pci 0000:3b:00.0: firmware crashed! (guid 
29b90296-0ef9-4140-8a80-abe8ab57a186)
[ 5954.587092] ath10k_pci 0000:3b:00.0: qca6174 hw3.2 target 0x05030000 chip_id 
0x00340aff sub 1a56:1535
[ 5954.587096] ath10k_pci 0000:3b:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 
0 testmode 0
[ 5954.588808] ath10k_pci 0000:3b:00.0: firmware ver 
WLAN.RM.4.4.1-00140-QCARMSWPZ-1 api 6 features wowlan,ignore-otp,mfp crc32 
29eb8ca1
[ 5954.590111] ath10k_pci 0000:3b:00.0: board_file api 2 bmi_id N/A crc32 
4ed3569e
[ 5954.590117] ath10k_pci 0000:3b:00.0: htt-ver 3.60 wmi-op 4 htt-op 3 cal otp 
max-sta 32 raw 0 hwcrypto 1
[ 5954.600293] ath10k_pci 0000:3b:00.0: failed to get memcpy hi address for 
firmware address 4: -16
[ 5954.600296] ath10k_pci 0000:3b:00.0: failed to read firmware dump area: -16
[ 5954.600300] ath10k_pci 0000:3b:00.0: Copy Engine register dump:
[ 5954.600336] ath10k_pci 0000:3b:00.0: [00]: 0x00034400  14  14   3   3
[ 5954.600369] ath10k_pci 0000:3b:00.0: [01]: 0x00034800   6   6  83  84
[ 5954.600465] ath10k_pci 0000:3b:00.0: [02]: 0x00034c00  57  57  55  56
[ 5954.600502] ath10k_pci 0000:3b:00.0: [03]: 0x00035000   9   9  11   9
[ 5954.600547] ath10k_pci 0000:3b:00.0: [04]: 0x00035400 3521 3517  31 223
[ 5954.600592] ath10k_pci 0000:3b:00.0: [05]: 0x00035800   0   0  64   0
[ 5954.600621] ath10k_pci 0000:3b:00.0: [06]: 0x00035c00  30  29   0  30
[ 5954.600636] ath10k_pci 0000:3b:00.0: [07]: 0x00036000   1   1   1   0
[ 5954.620584] ath10k_pci 0000:3b:00.0: failed to read hi_board_data address: 
-28
[ 5954.706228] ieee80211 phy0: Hardware restart was requested
[ 5954.921384] ath10k_pci 0000:3b:00.0: UART prints enabled
[ 5954.990174] ath10k_pci 0000:3b:00.0: unsupported HTC service id: 1536
[ 5955.493975] ath10k_pci 0000:3b:00.0: device successfully recovered
[ 6004.131362] wlp59s0: deauthenticating from b4:fb:e4:4b:1e:49 by local choice 
(Reason: 3=DEAUTH_LEAVING)
[ 6007.923710] ath10k_pci 0000:3b:00.0: UART prints enabled
[ 6007.992931] ath10k_pci 0000:3b:00.0: unsupported HTC service id: 1536

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1807974

Title:
  Wireless regularly breaking (ath10k firmware crashed!) after upgrade
  to Cosmic on Dell XPS 13 9370

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  I have a Dell XPS 13 9370 developer edition (Ubuntu version) running
  Cosmic. A handful of times per day, my wireless stops working ("?"
  appears in the icon in Network Manager). Turning wireless off and then
  on again, or suspending and waking the machine up, makes the wireless
  work again.

  dmesg output is as follows:

  $ dmesg | grep ath10k

  [ 6646.268929] ath10k_pci 0000:02:00.0: firmware crashed! (guid 
6317c652-4817-4fdd-b6d7-c7b8336e493f)
  [ 6646.268982] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 
chip_id 0x00340aff sub 1a56:143a
  [ 6646.268990] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 
dfs 0 testmode 0
  [ 6646.270369] ath10k_pci 0000:02:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [ 6646.271379] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 
20d869c3
  [ 6646.271393] ath10k_pci 0000:02:00.0: htt-ver 3.47 wmi-op 4 htt-op 3 cal 
otp max-sta 32 raw 0 hwcrypto 1
  [ 6646.283333] ath10k_pci 0000:02:00.0: failed to get memcpy hi address for 
firmware address 4: -16
  [ 6646.283336] ath10k_pci 0000:02:00.0: failed to read firmware dump area: -16
  [ 6646.283339] ath10k_pci 0000:02:00.0: Copy Engine register dump:
  [ 6646.283348] ath10k_pci 0000:02:00.0: [00]: 0x00034400  14  14   3   3
  [ 6646.283357] ath10k_pci 0000:02:00.0: [01]: 0x00034800  29  29 106 107
  [ 6646.283365] ath10k_pci 0000:02:00.0: [02]: 0x00034c00  20  19  18  19
  [ 6646.283374] ath10k_pci 0000:02:00.0: [03]: 0x00035000   8   8  10   8
  [ 6646.283386] ath10k_pci 0000:02:00.0: [04]: 0x00035400 2763 2763 167 103
  [ 6646.283394] ath10k_pci 0000:02:00.0: [05]: 0x00035800   0   0  64   0
  [ 6646.283402] ath10k_pci 0000:02:00.0: [06]: 0x00035c00   0   0   6   6
  [ 6646.283412] ath10k_pci 0000:02:00.0: [07]: 0x00036000   0   1   0   1
  [ 6646.301351] ath10k_pci 0000:02:00.0: failed to read hi_board_data address: 
-28
  [ 6647.126841] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
  [ 6647.129850] ath10k_pci 0000:02:00.0: Unknown eventid: 90118
  [ 6647.239340] ath10k_pci 0000:02:00.0: device successfully recovered

  
  [17641.847345] ath10k_pci 0000:02:00.0: firmware crashed! (guid 
03393f2f-0ce1-4017-b711-40dd14f2ec11)
  [17641.847363] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 
chip_id 0x00340aff sub 1a56:143a
  [17641.847367] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 
dfs 0 testmode 0
  [17641.848065] ath10k_pci 0000:02:00.0: firmware ver 
WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
  [17641.848585] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 
20d869c3
  [17641.848593] ath10k_pci 0000:02:00.0: htt-ver 3.47 wmi-op 4 htt-op 3 cal 
otp max-sta 32 raw 0 hwcrypto 1
  [17641.860559] ath10k_pci 0000:02:00.0: failed to get memcpy hi address for 
firmware address 4: -16
  [17641.860587] ath10k_pci 0000:02:00.0: failed to read firmware dump area: -16
  [17641.860595] ath10k_pci 0000:02:00.0: Copy Engine register dump:
  [17641.860611] ath10k_pci 0000:02:00.0: [00]: 0x00034400  14  14   3   3
  [17641.860624] ath10k_pci 0000:02:00.0: [01]: 0x00034800   6   6 243 244
  [17641.860639] ath10k_pci 0000:02:00.0: [02]: 0x00034c00  53  52  51  52
  [17641.860656] ath10k_pci 0000:02:00.0: [03]: 0x00035000   5   5   7   5
  [17641.860669] ath10k_pci 0000:02:00.0: [04]: 0x00035400 1231 1231 169 105
  [17641.860681] ath10k_pci 0000:02:00.0: [05]: 0x00035800   0   0  64   0
  [17641.860693] ath10k_pci 0000:02:00.0: [06]: 0x00035c00   0   0  30  30
  [17641.860706] ath10k_pci 0000:02:00.0: [07]: 0x00036000   0   1   0   1
  [17641.890915] ath10k_pci 0000:02:00.0: failed to read hi_board_data address: 
-28
  [17642.714052] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
  [17642.717154] ath10k_pci 0000:02:00.0: Unknown eventid: 90118
  [17642.835601] ath10k_pci 0000:02:00.0: device successfully recovered
  [17894.571696] ath10k_pci 0000:02:00.0: Unknown eventid: 118809
  [17894.574764] ath10k_pci 0000:02:00.0: Unknown eventid: 90118

  I do not recall having any wireless issues before I upgraded (when
  this machine was running Bionic).

  Bug #1730331 - ath10k_pci: firmware crashed!
  Bug #1627474 - ath10k_pci 0000:03:00.0: firmware crashed! (uuid n/a) [16.10]
  could be related, but appear to be related to earlier releases, whereas my 
issue has appeared/become much worse on Cosmic.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: linux-image-4.18.0-11-generic 4.18.0-11.12
  ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
  Uname: Linux 4.18.0-11-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.10-0ubuntu13.1
  Architecture: amd64
  AudioDevicesInUse:
   USER        PID ACCESS COMMAND
   /dev/snd/controlC0:  aaron-work   3476 F.... pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Dec 11 14:21:44 2018
  EcryptfsInUse: Yes
  HibernationDevice: RESUME=/dev/ubuntu-vg/swap_1
  InstallationDate: Installed on 2018-09-04 (98 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 0489:e0a2 Foxconn / Hon Hai 
   Bus 001 Device 002: ID 0bda:58f4 Realtek Semiconductor Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. XPS 13 9370
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.18.0-11-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash 
resume=/dev/mapper/ubuntu-vg-swap_1 vt.handoff=1
  RelatedPackageVersions:
   linux-restricted-modules-4.18.0-11-generic N/A
   linux-backports-modules-4.18.0-11-generic  N/A
   linux-firmware                             1.175.1
  SourcePackage: linux
  UpgradeStatus: Upgraded to cosmic on 2018-10-26 (45 days ago)
  WifiSyslog:
   
  dmi.bios.date: 08/09/2018
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.5.1
  dmi.board.name: 0F6P3V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.5.1:bd08/09/2018:svnDellInc.:pnXPS139370:pvr:rvnDellInc.:rn0F6P3V:rvrA00:cvnDellInc.:ct10:cvr:
  dmi.product.family: XPS
  dmi.product.name: XPS 13 9370
  dmi.product.sku: 07E6
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1807974/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to