Hi, could you also try https://vicamo.gitlab.io/-/backport-iwlwifi-
dkms/-/jobs/401941479/artifacts/aptly/index.html ? This is the
unofficial backport-iwlwifi-dkms apt from daily CI. Please have a try
and attach dmesg log. If this still fails, then we'd need a public bug
for Intel.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  iwlwifi broken for Killer Wi-Fi 6 AX1650i with 5.4/20.04

Status in linux package in Ubuntu:

Bug description:
  Hi there,

  Laptop: Dell XPS 13 7390 2-in-1
  Built-in wireless: Killer Wi-Fi 6 AX1650i 160MHz

  iwlwifi worked fine with 19.10 but breaks when upgrading to 20.04.
  Firmware crashes after loading and interface doesn't show up.

  This is with:
  linux-image-5.4.0-9-generic           5.4.0-9.12
  linux-firmware 1.184

  I've noticed the driver was trying to load a more recent firmware:
  Direct firmware load for iwlwifi-Qu-b0-hr-b0-50.ucode failed with error -2

  I've downloaded this file from upstream iwlwifi firmware git and tried
  unloading/reloading iwlwifi. Driver crashes as well, but with a
  different error code.

  - LM

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: linux-image-5.4.0-9-generic 5.4.0-9.12
  ProcVersionSignature: Ubuntu 5.4.0-9.12-generic 5.4.3
  Uname: Linux 5.4.0-9-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu15
  Architecture: amd64
   /dev/snd/controlC0:  lool       1579 F.... pulseaudio
   /dev/snd/pcmC0D0p:   lool       1579 F...m pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Jan 11 15:02:08 2020
  InstallationDate: Installed on 2019-12-02 (39 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  MachineType: Dell Inc. XPS 13 7390 2-in-1
   PATH=(custom, no user)
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-9-generic 
root=UUID=854f3bc2-da3a-4a3c-82a1-6b04a932bb29 ro pcie_aspm=off 
plymouth.force-scale=3 quiet splash vt.handoff=7
   linux-restricted-modules-5.4.0-9-generic N/A
   linux-backports-modules-5.4.0-9-generic  N/A
   linux-firmware                           1.184
   0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: Upgraded to focal on 2020-01-11 (0 days ago)
  dmi.bios.date: 11/10/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.1.3
  dmi.board.name: 06CDVY
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 31
  dmi.chassis.vendor: Dell Inc.
  dmi.product.family: XPS
  dmi.product.name: XPS 13 7390 2-in-1
  dmi.product.sku: 08B0
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to