** Changed in: linux-restricted-modules (Ubuntu)
     Assignee: (unassigned) => Andy Whitcroft (apw)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-restricted-modules in Ubuntu.
https://bugs.launchpad.net/bugs/1856414

Title:
  installing linux-modules-nvidia does not remove nvidia-dkms, and the
  kernel prioritizes the wrong version of the module from disk

Status in linux-restricted-modules package in Ubuntu:
  New
Status in nvidia-graphics-drivers-430 package in Ubuntu:
  New

Bug description:
  Installing nvidia-driver-430 pulls in nvidia-dkms-430 as a dependency.
  Installing linux-modules-nvidia-430-generic does not satisfy this
  dependency in its place; so nvidia-dkms-430 can't be removed without
  also removing nvidia-driver-430, and then a bunch of other packages
  also want to be removed as unused:

  $ sudo apt purge nvidia-dkms-430
  Reading package lists... Done
  Building dependency tree       
  Reading state information... Done
  The following packages were automatically installed and are no longer 
required:
    dkms libatomic1:i386 libbsd0:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386
    libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
    libelf1:i386 libexpat1:i386 libffi6:i386 libgl1:i386 libgl1-mesa-dri:i386
    libglapi-mesa:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386
    libllvm9:i386 libnvidia-cfg1-430 libnvidia-common-430 libnvidia-compute-430
    libnvidia-compute-430:i386 libnvidia-decode-430 libnvidia-decode-430:i386
    libnvidia-encode-430 libnvidia-encode-430:i386 libnvidia-fbc1-430
    libnvidia-fbc1-430:i386 libnvidia-gl-430 libnvidia-gl-430:i386
    libnvidia-ifr1-430 libnvidia-ifr1-430:i386 libpciaccess0:i386
    libsensors5:i386 libstdc++6:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386
    libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
    libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
    libxfixes3:i386 libxnvctrl0 libxshmfence1:i386 libxxf86vm1:i386
    nvidia-compute-utils-430 nvidia-kernel-source-430 nvidia-prime
    nvidia-settings nvidia-utils-430 screen-resolution-extra
    xserver-xorg-video-nvidia-430
  Use 'sudo apt autoremove' to remove them.
  The following packages will be REMOVED:
    nvidia-dkms-430* nvidia-driver-430*
  0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
  After this operation, 1,269 kB disk space will be freed.
  Do you want to continue? [Y/n] n
  Abort.
  $

  And it's not sufficient to leave both linux-modules-nvidia and nvidia-
  dkms installed, because when both are present, the kernel erroneously
  picks up the modules from nvidia-dkms first, and fails to load them if
  SecureBoot is on and the local MOK is not enrolled.

  linux-modules-nvidia-430-generic probably needs a versioned Provides:
  so that it can be installed in place of nvidia-dkms-430.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules/+bug/1856414/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to