[    0.752256] microcode: sig=0x806ec, pf=0x80, revision=0xd6
[    0.752261] microcode: Microcode Update Driver: v2.2.

So this might be a duplicate of bug 1862751.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Dell Latitude/Precision: Linux hangs without plugged in power cable

Status in intel-microcode package in Ubuntu:
Status in linux package in Ubuntu:

Bug description:
  Already present reported in project *dell-sputnik*. (Note, it happened
  here also without suspend/resume.):

  1.  https://bugs.launchpad.net/dell-sputnik/+bug/1661741
  2.  Quote from 

      > A similar bug affects several Dell laptop models:
      > - Dell 5480/5488 :
      >  https://bugs.launchpad.net/dell-sputnik/+bug/1866343
      > - Dell E5470 :
      > https://bugs.launchpad.net/dell-sputnik/+bug/1661741
      > (Note that the bug https://bugs.launchpad.net/dell-sputnik/+bug/1661741 
is not fixed; it has been changed, by error, to fixed. Please, it will be nice 
if somebody can change the status to "confirmed")
      > - Dell 7740 :
      > https://bugs.launchpad.net/dell-sputnik/+bug/1871491
      > I suppose that the bug can also affect Dell precision 7730

  After experiencing this already on the Dell Latitude 5480/5488
  (https://bugs.launchpad.net/dell-sputnik/+bug/1866343), we have seen
  this now too with the Dell Precision 3540 (with dedicated AMD graphics

  Without the power cord plugged in, the system started fine, then
  updating packages, including the Linux kernel, turning the system off,
  and right back on, it went to GRUB, and GRUB was able to load Linux
  and initrd, and starting Linux it hung.

  Num lock key didn’t respond (but also didn’t blink – no idea if this
  should work), and Ctrl + Alt + Del didn’t work either. So, the system
  had to be powered off by pressing the power button for some (ten(?))

  Subsequent tries didn’t help, until we remembered the issues with the
  other device, and plugging in the power cord fixed it.

  With the power cable unplugged, it didn’t boot.

  The state of the connected power cable only mattered, when starting
  the Linux kernel. That means, plugging it in, when GRUB was active,
  the system booted. Removing the cable, when GRUB was running, Linux

  I tried to get Linux messages, but `debug nomodeset earlyprintk=efi`
  didn’t get Linux to output any messages.

  ### Workarounds ###

  I was able to get Linux booting by adding either one of the following
  Linux kernel parameters.

  1.  `maxcpus=1` (once it started with `maxcpus=2`)
  2.  `nosmp`
  2.  `acpi=off`
  3.  `nolapic`

  In this state, there was only one CPU online. Trying to bring one more
  online, the system always froze instantly.

      echo 1 | sudo tee /sys/devices/system/cpu/cpu1/online

  (Nothing in pstore either.) (Where maxcpus=2` worked, we were able to
  bring a third CPU online, but the system froze when trying the

  ### Reproducibilty ###

  Letting the system sit over night, and trying again in the morning,
  unfortunately, we did *not* test without a power cable plugged in, as
  we had an idea to test the non-USB-Type-C power cable. With that the
  system started.

  Powering the system off, and unplugging the cable, the system booted
  without issues. So something changed.

  We weren’t able to get it into a state, where it doesn’t boot in the
  last hour, but we would like this investigated, as we are giving these
  systems to our users.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to