Does cold boot help?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  RTL8822BE Wifi [10ec:b822] subsystem [17aa:b023] crashes on 20.04 on
  Lenovo Legion Y530

Status in Ubuntu MATE:
Status in linux package in Ubuntu:

Bug description:
  After upgrading Ubuntu Mate  to 20.04 , my wifi crashed on Lenovo legion 
Y530. The strange thing is that it connects to the network, i have internet for 
some time (usually between 1 and 10 minutes) and then it disconnects.
  After that, the applet shows me something like device not ready and i can 
only restart the computer to connect. Then it crashes again... 
  I also tried a fresh install with the same results.
  I used 19.04 and 19.10 on the same laptop as my primary operating system and 
wifi worked flawlessly.

  Since I do my work on this laptop i was forced to downgrade back to 19.10 for 
  This is my lshw -C network (from 19.10 If I remember correctly it was 
RTL8822BE also in 20.04)
         description: Wireless interface
         product: RTL8822BE 802.11a/b/g/n/ac WiFi adapter
         vendor: Realtek Semiconductor Co., Ltd.
         physical id: 0
         bus info: pci@0000:07:00.0
         logical name: wlp7s0
         version: 00
         serial: dc:a2:66:80:7d:7d
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress bus_master cap_list ethernet physical 
         configuration: broadcast=yes driver=rtw_pci 
driverversion=5.3.0-46-generic firmware=N/A ip= latency=0 link=yes 
multicast=yes wireless=IEEE 802.11
         resources: irq:141 ioport:4000(size=256) memory:a4300000-a430ffff
         description: Ethernet interface
         product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
         vendor: Realtek Semiconductor Co., Ltd.
         physical id: 0
         bus info: pci@0000:08:00.0
         logical name: enp8s0
         version: 15
         serial: 8c:16:45:e9:e9:a8
         capacity: 1Gbit/s
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress msix bus_master cap_list ethernet 
physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
         configuration: autonegotiation=on broadcast=yes driver=r8169 
firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII
         resources: irq:17 ioport:3000(size=256) memory:a4204000-a4204fff 

  and my lspci -nnk | grep -A2 0280

  07:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8822BE 
802.11a/b/g/n/ac WiFi adapter [10ec:b822]
        Subsystem: Lenovo RTL8822BE 802.11a/b/g/n/ac WiFi adapter [17aa:b023]
        Kernel driver in use: rtw_pci

  If you think it is necessary, I can try to install 20.04 on an external hard 
drive and give you some more info from there.
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
   /dev/snd/controlC0:  campus     1207 F.... pulseaudio
  CasperMD5CheckResult: skip
  CurrentDesktop: MATE
  DistroRelease: Ubuntu 20.04
  InstallationDate: Installed on 2020-05-09 (0 days ago)
  InstallationMedia: Ubuntu-MATE 20.04 LTS "Focal Fossa" - Release amd64 
  MachineType: LENOVO 81FV
  NonfreeKernelModules: nvidia_modeset nvidia
  Package: linux (not installed)
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-29-generic 
root=UUID=2ba3f662-50a5-4db8-a5e1-ddaf5e09d5a9 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
   linux-restricted-modules-5.4.0-29-generic N/A
   linux-backports-modules-5.4.0-29-generic  N/A
   linux-firmware                            1.187
  Tags:  focal
  Uname: Linux 5.4.0-29-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  _MarkForUpload: True 07/18/2018
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8JCN43WW
  dmi.board.asset.tag: NO Asset Tag LNVNB161216
  dmi.board.vendor: LENOVO
  dmi.board.version: NO DPK
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo Legion Y530-15ICH
dmi:bvnLENOVO:bvr8JCN43WW:bd07/18/2018:svnLENOVO:pn81FV:pvrLenovoLegionY530-15ICH:rvnLENOVO:rnLNVNB161216:rvrNODPK:cvnLENOVO:ct10:cvrLenovoLegionY530-15ICH: Legion Y530-15ICH 81FV
  dmi.product.sku: LENOVO_MT_81FV_BU_idea_FM_Legion Y530-15ICH
  dmi.product.version: Lenovo Legion Y530-15ICH
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to