** Changed in: linux-oem (Ubuntu Bionic)
       Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-oem in Ubuntu.
https://bugs.launchpad.net/bugs/1856387

Title:
  Freezing on boot since kernel 4.15.0-72-generic release

Status in linux package in Ubuntu:
  Invalid
Status in linux-oem package in Ubuntu:
  Invalid
Status in linux source package in Bionic:
  Fix Committed
Status in linux-oem source package in Bionic:
  Fix Committed

Bug description:
  [SRU Justification]

  [Impact]
  In bug 1840239, HPET is disabled on some systems for they caused TSC
  being marked unstable while it is not. This caused an regression as bug
  1851216 that some systems may then hang at early, so a fix cherry picked
  back from v5.3-rc1. However, this fix also introduce yet another
  regression that some other users may hang at boot while PIT is diabled
  in the previous fix.

  [Fix]
  Commit 979923871f69 ("x86/timer: Don't skip PIT setup when APIC is
  disabled or in legacy mode") from v5.6-rc1, also backported to v5.4.19
  and v5.5.3, fixes PIT setup in this case.

  [Test Case]
  Simply boot a patch kernel on systems affected and it shouldn't hang.

  [Regression Potential]
  Low. Stable patch and trivial backport.

  [Other Info]
  The same fix for bug 1851216 was also backported to Disco and Eoan, but
  they were then fixed with this 979923871f69 commit backported in bug
  1866858 and bug 1867051, which pulls v5.4 stable patches into Disco and
  Eoan correspondingly, leaving B/OEM-B the only victims so far.

  ========== Original Bug Description ==========

  After the update to install kernel 4.15.0-72-generic (a bit over a week ago) 
my computer will not boot. On boot, all I see is the purple screen with:
  Loading Linux 4.15.0-72-generic ...
  Loading initial ramdisk ...
  and nothing happens. Just sits there. I've waited about 5-10 minutes on 
occasion but to no avail.
  I've checked a number of logs in /var/log but not found anything.

  If I go into the advanced options and select kernel
  4.15.0-70-generic, the computer boots normally.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: linux-image-4.15.0-72-generic 4.15.0-72.81
  ProcVersionSignature: Ubuntu 4.15.0-70.79-generic 4.15.18
  Uname: Linux 4.15.0-70-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.9
  Architecture: amd64
  AudioDevicesInUse:
   USER        PID ACCESS COMMAND
   /dev/snd/controlC0:  tony       1977 F.... pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Dec 14 21:53:14 2019
  HibernationDevice: RESUME=UUID=5475ce25-e091-45e2-9811-9b5cddc08dd1
  InstallationDate: Installed on 2018-09-16 (454 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 04f2:b59e Chicony Electronics Co., Ltd
   Bus 001 Device 002: ID 046d:c063 Logitech, Inc. DELL Laser Mouse
   Bus 001 Device 004: ID 8087:0aaa Intel Corp.
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: GIGABYTE Sabre 17WV8
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-70-generic 
root=UUID=9455257c-d3b7-4d61-853d-ab0b0ee40013 ro acpi=off
  RelatedPackageVersions:
   linux-restricted-modules-4.15.0-70-generic N/A
   linux-backports-modules-4.15.0-70-generic  N/A
   linux-firmware                             1.173.13
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/22/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F05
  dmi.board.asset.tag: Tag 12345
  dmi.board.name: Sabre 17WV8
  dmi.board.vendor: GIGABYTE
  dmi.board.version: Not Applicable
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: GIGABYTE
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrF05:bd05/22/2018:svnGIGABYTE:pnSabre17WV8:pvrNotApplicable:rvnGIGABYTE:rnSabre17WV8:rvrNotApplicable:cvnGIGABYTE:ct10:cvrN/A:
  dmi.product.family: Sabre
  dmi.product.name: Sabre 17WV8
  dmi.product.version: Not Applicable
  dmi.sys.vendor: GIGABYTE

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1856387/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to